aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-20 15:46:09 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2020-12-28 10:19:51 +0000
commit4185bdc00ef42443f85ff19a5a449a2904bec285 (patch)
treee2e0832fcde7496c4071a6795f4f41ec1687ec19
parente2266d8c8d7c3c89dc53621ca595a3eba94a7809 (diff)
main/libtheora: drop sdl dependency
This is used only for the examples package and removing this allows us to move sdl1 to main/
-rw-r--r--main/libtheora/APKBUILD25
1 files changed, 4 insertions, 21 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index 69e995f4ad5..32825bcb92a 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtheora
pkgver=1.1.1
-pkgrel=15
+pkgrel=16
pkgdesc="An open video codec developed by the Xiph.org"
url="https://www.xiph.org"
arch="all"
license="BSD-3-Clause"
-subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-examples"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
depends_dev="libogg-dev"
-makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool
+makedepends="libvorbis-dev libogg-dev autoconf automake libtool
linux-headers"
-source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
+source="http://downloads.xiph.org/releases/theora/libtheora-$pkgver.tar.bz2
libtheora-flags.patch
enc.patch
fix-timeb.patch
@@ -20,9 +20,6 @@ source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
prepare() {
default_prepare
- cd "$builddir"
-
- sed -i 's/png_\(sizeof\)/\1/g' examples/png2theora.c
libtoolize --force
aclocal -I m4
@@ -31,8 +28,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
CFLAGS="${CFLAGS/-Os/-O3}" CPPFLAGS="${CPPFLAGS/-Os/-O3}" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,25 +39,13 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
}
-examples() {
- pkgdesc="Example applications for libtheora"
-
- cd "$builddir"/examples/.libs
-
- install -d "$subpkgdir"/usr/bin
- install -m755 dump_psnr player_example dump_video encoder_example \
- "$subpkgdir"/usr/bin/
-}
-
static() {
depends=""
pkgdesc="$pkgdesc (static libraries)"