aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-22 19:23:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-22 23:47:24 +0000
commit43df58a70b7148510767278b7bc9fe87cc6e0906 (patch)
tree29e64965e315a3a9f33929bc2cfdef9fcd84d0d2
parentc696d09f56655826b69031eab4d70afb72c9cb16 (diff)
community/editorconfig: use CMAKE_BUILD_TYPE=None
-rw-r--r--community/editorconfig/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/editorconfig/APKBUILD b/community/editorconfig/APKBUILD
index 67fd7ce7e82..65245a132f4 100644
--- a/community/editorconfig/APKBUILD
+++ b/community/editorconfig/APKBUILD
@@ -5,7 +5,7 @@ _pkgname=$pkgname-core-c
pkgver=0.12.3
_testname=editorconfig-core-test
_testver=0.12
-pkgrel=0
+pkgrel=1
pkgdesc="EditorConfig core library written in C (for use by plugins supporting EditorConfig parsing)"
url="https://github.com/editorconfig/editorconfig-core-c"
arch="all"
@@ -13,7 +13,7 @@ license="BSD-2-Clause"
makedepends="cmake pcre2-dev"
subpackages="lib$pkgname:libs $pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/editorconfig/$_pkgname/archive/v$pkgver.tar.gz
- https://github.com/editorconfig/$_testname/archive/v${_testver}.tar.gz
+ https://github.com/editorconfig/$_testname/archive/v$_testver.tar.gz
disable-failing-test.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -21,13 +21,13 @@ builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
# Tests are taken from a github release tarball so place them in the tree
rmdir tests
- mv ../${_testname}-${_testver} tests
+ mv ../$_testname-$_testver tests
default_prepare
}
build() {
cmake . \
- -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_C_FLAGS_MINSIZEREL="$CFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \