aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-16 11:30:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-16 11:40:26 +0000
commit449f45f86182f027655dbb931cb1bf7835374cd1 (patch)
tree18106fed77c5811ea3548c86b4f6ae7beabbe59e
parent215c3fc9ba428054c74b1d8da56eb700d3888a70 (diff)
main/py-icu: enable python3 and claim maintainership
-rw-r--r--main/py-icu/APKBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/main/py-icu/APKBUILD b/main/py-icu/APKBUILD
index 2dc60d71f24..8e1c0924aab 100644
--- a/main/py-icu/APKBUILD
+++ b/main/py-icu/APKBUILD
@@ -1,30 +1,43 @@
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-icu
_pkgname=PyICU
pkgver=1.9.6
-pkgrel=2
+pkgrel=3
pkgdesc="Python binding for ICU"
url="http://pyicu.osafoundation.org/"
arch="all"
license="MIT"
-depends="python2"
-makedepends="python2-dev icu-dev"
+makedepends="python2-dev python3-dev icu-dev"
+subpackages="py2-icu:_py py3-icu:_py"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
check() {
cd "$builddir"
python2 setup.py check
+ python3 setup.py check
}
build() {
cd "$builddir"
python2 setup.py build
+ python3 setup.py build
}
package() {
cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+_py() {
+ local py=${subpkgname%%-*}
+ local python="python${py#py}"
+ depends="$python"
+ pkgdesc="$pkgdesc ($python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/${python}* "$subpkgdir"/usr/lib/
}
sha512sums="51ae0876dbe79c696a7630ec184049df685eebc4660b439b8a3e6e86ef37dfa8cdd0fd6895fc230f954baad30528f4017a7b6a17edc8f7e8b9e4c1bd729d447a PyICU-1.9.6.tar.gz"