aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-14 22:32:07 +0200
committerprspkt <prspkt@protonmail.com>2019-03-15 00:27:18 +0200
commit46a92ee5c4c1d41f8891838c0c56a3a34a035a0d (patch)
tree590401f5e811e9cea889526faca8c56fe817a798
parentff86eb2e1871f910724d0c9a662fda7093af4bda (diff)
community/gsoap: upgrade to 2.8.82
Remove unused patches Append -D_GNU_SOURCE CFLAG to resolve implicit declaration warnings
-rw-r--r--community/gsoap/APKBUILD14
-rw-r--r--community/gsoap/musl-fixes.patch45
-rw-r--r--community/gsoap/musl-needs-_GNU_SOURCE-too.patch44
3 files changed, 5 insertions, 98 deletions
diff --git a/community/gsoap/APKBUILD b/community/gsoap/APKBUILD
index 02f2b2f43ce..c7ebd0be8a9 100644
--- a/community/gsoap/APKBUILD
+++ b/community/gsoap/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: <xmingske@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gsoap
-pkgver=2.8.80
+pkgver=2.8.82
pkgrel=0
arch="all"
pkgdesc="Cross-platform C and C++ SDK for SOAP/XML Web services"
@@ -9,10 +9,7 @@ license="GPL-2.0-or-later gSOAP-1.3b"
url="http://gsoap2.sourceforge.net"
makedepends="autoconf automake bison flex openssl-dev libtool zlib-dev"
subpackages="$pkgname-dev"
-source="https://downloads.sourceforge.net/project/gsoap2/gsoap-${pkgver%.*}/gsoap_$pkgver.zip
- musl-fixes.patch
- musl-needs-_GNU_SOURCE-too.patch
- "
+source="https://downloads.sourceforge.net/project/gsoap2/gsoap-${pkgver%.*}/gsoap_$pkgver.zip"
builddir="$srcdir/$pkgname-${pkgver%.*}"
build() {
@@ -23,7 +20,8 @@ build() {
--infodir=/usr/share/info \
--exec-prefix=/usr \
--enable-ipv6 \
- --enable-c-locale
+ --enable-c-locale \
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
make -j1
}
@@ -32,6 +30,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="7018f9904d6b3cd5f0d6dacdd03e399fa01df450ec37a4fd29988657b639b86027da62ffc8b03b79a05547e80250fb974b56784fb57e4583899bc8c1958aa8e1 gsoap_2.8.80.zip
-97b4b932807b74436331e4a665a6f36f49e4533107d3948e45659d2cdf939c9d24650e7233e1a3a9e3e87db6a7821ab0a4502454d2579fff9e7a5f0b1f2cbb03 musl-fixes.patch
-663fb1572e0e6283bb9ef994b2e2a0f828d25a69454447d5a2b602aa396c8fe57c1b3c4098e5c26603e693931ac17d8dc5702c8ef6a00b8fec6a43ff9317a05c musl-needs-_GNU_SOURCE-too.patch"
+sha512sums="daf6a1870fe43beb20d0faf646b171c92629885708baabea5bbce79fa5a8030f014dbe5c0bf4024031df993dd3ed3a90449db813946cfdfa9c12318096b57eec gsoap_2.8.82.zip"
diff --git a/community/gsoap/musl-fixes.patch b/community/gsoap/musl-fixes.patch
deleted file mode 100644
index ae706d13be9..00000000000
--- a/community/gsoap/musl-fixes.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/gsoap/stdsoap2.c 2019-02-20 22:32:37.000000000 +0200
-+++ b/gsoap/stdsoap2.c 2019-02-21 13:47:00.423192212 +0200
-@@ -5099,7 +5099,7 @@ tcp_gethost(struct soap *soap, const cha
- return soap->error = SOAP_EOM;
- return SOAP_OK;
- }
--#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
-+#if defined(LINUX) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
- if (gethostbyname_r(addr, &hostent, soap->buf, sizeof(soap->buf), &host, &soap->errnum) < 0)
- host = NULL;
- #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R))
-Only in gsoap-2.8/gsoap: stdsoap2.c.orig
---- a/gsoap/stdsoap2.cpp 2019-02-20 22:32:37.000000000 +0200
-+++ b/gsoap/stdsoap2.cpp 2019-02-21 13:47:00.428192236 +0200
-@@ -5099,7 +5099,7 @@ tcp_gethost(struct soap *soap, const cha
- return soap->error = SOAP_EOM;
- return SOAP_OK;
- }
--#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
-+#if defined(LINUX) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__)
- if (gethostbyname_r(addr, &hostent, soap->buf, sizeof(soap->buf), &host, &soap->errnum) < 0)
- host = NULL;
- #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R))
-@@ -22307,7 +22307,7 @@ soap_strerror(struct soap *soap)
- {
- #ifndef WIN32
- # ifdef HAVE_STRERROR_R
--# if ((!defined(_POSIX_C_SOURCE) || !defined(_XOPEN_SOURCE) || _POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && !_GNU_SOURCE) || defined(__ANDROID__)
-+# if ((!defined(_POSIX_C_SOURCE) || !defined(_XOPEN_SOURCE) || _POSIX_C_SOURCE >= 200112L || _XOPEN_SOURCE >= 600) && !_GNU_SOURCE) || defined(__ANDROID__) || !defined(__GLIBC__)
- strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* XSI-compliant */
- # else
- return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */
-Only in gsoap-2.8/gsoap: stdsoap2.cpp.orig
---- a/gsoap/stdsoap2.h 2019-02-20 22:32:37.000000000 +0200
-+++ b/gsoap/stdsoap2.h 2019-02-21 13:47:00.428192236 +0200
-@@ -998,7 +998,7 @@ extern "C" {
- # endif
- #elif defined(SOCKLEN_T)
- # define SOAP_SOCKLEN_T SOCKLEN_T
--#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE)
-+#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE) || defined (LINUX)
- # define SOAP_SOCKLEN_T socklen_t
- #elif defined(IRIX) || defined(WIN32) || defined(__APPLE__) || defined(SUN_OS) || defined(OPENSERVER) || defined(TRU64) || defined(VXWORKS)
- # define SOAP_SOCKLEN_T int
-Only in gsoap-2.8/gsoap: stdsoap2.h.orig
diff --git a/community/gsoap/musl-needs-_GNU_SOURCE-too.patch b/community/gsoap/musl-needs-_GNU_SOURCE-too.patch
deleted file mode 100644
index 9b953b10f00..00000000000
--- a/community/gsoap/musl-needs-_GNU_SOURCE-too.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/gsoap/VisualStudio2005/wsdl2h/wsdl2h/stdsoap2.cpp
-+++ b/gsoap/VisualStudio2005/wsdl2h/wsdl2h/stdsoap2.cpp
-@@ -58,7 +58,7 @@
- # pragma convert(819) /* EBCDIC to ASCII */
- #endif
-
--#if defined(__gnu_linux__) && !defined(_GNU_SOURCE)
-+#if defined(__linux__) && !defined(_GNU_SOURCE)
- # define _GNU_SOURCE 1
- #endif
-
---- a/gsoap/samples/calc_vs2005/calc_vs2005/stdsoap2.cpp
-+++ b/gsoap/samples/calc_vs2005/calc_vs2005/stdsoap2.cpp
-@@ -58,7 +58,7 @@
- # pragma convert(819) /* EBCDIC to ASCII */
- #endif
-
--#if defined(__gnu_linux__) && !defined(_GNU_SOURCE)
-+#if defined(__linux__) && !defined(_GNU_SOURCE)
- # define _GNU_SOURCE 1
- #endif
-
---- a/gsoap/stdsoap2.c
-+++ b/gsoap/stdsoap2.c
-@@ -58,7 +58,7 @@
- # pragma convert(819) /* EBCDIC to ASCII */
- #endif
-
--#if defined(__gnu_linux__) && !defined(_GNU_SOURCE)
-+#if defined(__linux__) && !defined(_GNU_SOURCE)
- # define _GNU_SOURCE 1
- #endif
-
---- a/gsoap/stdsoap2.cpp
-+++ b/gsoap/stdsoap2.cpp
-@@ -58,7 +58,7 @@
- # pragma convert(819) /* EBCDIC to ASCII */
- #endif
-
--#if defined(__gnu_linux__) && !defined(_GNU_SOURCE)
-+#if defined(__linux__) && !defined(_GNU_SOURCE)
- # define _GNU_SOURCE 1
- #endif
-