aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-26 11:14:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-26 11:14:40 +0000
commit4744387683e900d45503af27f4e2b0ca0b738adb (patch)
treef2c3342c1d7a5aa714e5463451de679ca9bbd424
parent3e16984a0048112b2795a00dc9cf3a9100154ebe (diff)
testing/hsetroot: new aport
Yet another wallpaper application https://github.com/himdel/hsetroot fixes #11039
-rw-r--r--testing/hsetroot/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/hsetroot/APKBUILD b/testing/hsetroot/APKBUILD
new file mode 100644
index 00000000000..f6f3ec67cce
--- /dev/null
+++ b/testing/hsetroot/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname="hsetroot"
+pkgver="1.0.5"
+pkgrel=0
+pkgdesc="Yet another wallpaper application"
+url="https://github.com/himdel/hsetroot"
+arch="all"
+license="GPL-2.0-only"
+makedepends="imlib2-dev libx11-dev libxinerama-dev"
+source="https://github.com/himdel/hsetroot/archive/$pkgver/hsetroot-$pkgver.tar.gz"
+builddir="$srcdir/hsetroot-$pkgver"
+options="!check"
+
+build() {
+ make
+}
+
+package() {
+ install -d "$pkgdir"/usr/bin
+ make PREFIX="$pkgdir"/usr install
+}
+
+sha512sums="b43f7cd75886e72cb6134446d383d7d9a684c818f2d8a0f829670c8dfca5eaaa1eb6c25f30dda41f3483609b25e8a44a3a3cb3a969bba7f77a9b9df712fa2167 hsetroot-1.0.5.tar.gz"