aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-13 05:30:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-13 08:04:49 -0300
commit47b52e878e5d803ceb888a1404a311e19f30cb6e (patch)
treea86d7a0f88bc84db4dcf169cba0ee3f6008cf65f
parent873dbe41e3007001cf67a565f67dd50a54158d6d (diff)
main/pcre: upgrade to 8.44
-rw-r--r--main/pcre/APKBUILD18
1 files changed, 2 insertions, 16 deletions
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index df56bda972d..d642aa8b13e 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -1,14 +1,12 @@
# Contributor: Sergei Lukin <sergej.lukin@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pcre
-pkgver=8.43
+pkgver=8.44
pkgrel=0
pkgdesc="Perl-compatible regular expression library"
url="http://pcre.sourceforge.net"
arch="all"
license="BSD-3-Clause"
-depends=
-makedepends=""
checkdepends="paxmark"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcrecpp libpcre16 libpcre32"
@@ -20,11 +18,8 @@ source="https://ftp.pcre.org/pub/pcre/pcre-$pkgver.tar.bz2"
# - CVE-2017-11164
# - CVE-2017-16231
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
local _enable_jit="--enable-jit"
case "$CARCH" in
mips64*) export CPPFLAGS="$CPPFLAGS -DSLJIT_IS_FPU_AVAILABLE=0";;
@@ -50,19 +45,10 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
check() {
- cd "$builddir"
-
- # paxmark tests requiring JIT
- for fn in pcre_jit_test pcretest; do
- ./$fn &>/dev/null < /dev/null || true
- [ -x .libs/lt-$fn ] && paxmark -m .libs/lt-$fn
- done
-
# skip locale specific tests
sed -i -e 's/do3=yes//g' RunTest
@@ -93,4 +79,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="3b4ac2c7ccd77c9575d07a33c3456f40b50731029e62d01fb8f2f5871d7118e12bc9e6bc7a8079769c765e38da5ecf98c4b261b10ff0a2f14f0881b434f67af7 pcre-8.43.tar.bz2"
+sha512sums="f26d850aab5228799e58ac8c2306fb313889332c39e29b118ef1de57677c5c90f970d68d3f475cabc64f8b982a77f04eca990ff1057f3ccf5e19bd137997c4ac pcre-8.44.tar.bz2"