aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni+alpine@hack.org>2021-03-08 12:52:31 +0000
committerLeo <thinkabit.ukim@gmail.com>2021-03-08 23:48:25 +0000
commit49a5000490223581a5a16f376e8fd7486ebf6d5c (patch)
treeb3efb0735ac3e5cf0e63e4087e867bdc28d2ea88
parent8f8aa99618d06edeb0ebe0818e2f3f877a76bc1c (diff)
testing/havoc: new aport
-rw-r--r--testing/havoc/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/havoc/APKBUILD b/testing/havoc/APKBUILD
new file mode 100644
index 00000000000..c27f4b04143
--- /dev/null
+++ b/testing/havoc/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: omni <omni+alpine@hack.org>
+pkgname=havoc
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="terminal emulator for Wayland"
+arch="all"
+url="https://github.com/ii8/havoc"
+license="PD OR MIT"
+makedepends="wayland-dev wayland-protocols libxkbcommon-dev"
+options="!check" # no test suite
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ii8/havoc/archive/$pkgver.tar.gz"
+
+build() {
+ make havoc
+}
+
+package() {
+ install -Dm0755 "$pkgname" -t "$pkgdir"/usr/bin
+
+ install -Dm0644 "$pkgname".cfg -t "$pkgdir"/usr/share/doc/"$pkgname"
+ install -Dm0644 LICENSE -t "$pkgdir"/usr/share/licenses/"$pkgname"
+}
+
+sha512sums="362236bf9317619a7c5099b4c6643c632ef22fa9ff651f55566f25c7e05363befc1a4cf374adf9cf156c249a3a9a3721c1af2ecd310012affcd413413d41cefd havoc-0.3.1.tar.gz"