aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-07-24 20:35:23 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-07-30 11:25:15 +0000
commit4b1eb252537a85f8327afc7b5d50465cd689c9e9 (patch)
tree78615d01950c856fc5e7f79daabb03efa411a49b
parent394e12f188601a4b8fa99e1ec506359d800932d1 (diff)
community/libQuotient: upgrade to 0.6.0
-rw-r--r--community/libquotient/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/community/libquotient/APKBUILD b/community/libquotient/APKBUILD
index 64048e69131..26d8fd359e1 100644
--- a/community/libquotient/APKBUILD
+++ b/community/libquotient/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=libquotient
-pkgver=0.5.3.2_git20200814
+pkgver=0.6.0
pkgrel=0
-_commit="58dfe74390ebdd8ec6611d3b8fecfe7d051ff955"
pkgdesc="Qt5 library for cross-platform clients for Matrix"
url="https://github.com/quotient-im/libQuotient"
arch="all !armhf" # blocked by qt5-qtmultimedia
@@ -11,9 +10,9 @@ license="LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev qt5-qtmultimedia-dev libqtolm-dev"
makedepends="$depends_dev cmake"
subpackages="$pkgname-dev"
-source="https://github.com/quotient-im/libQuotient/archive/$_commit/libQuotient-$_commit.tar.gz"
-options="!check" # No testsuite
-builddir="$srcdir/libQuotient-$_commit"
+source="https://github.com/quotient-im/libQuotient/archive/$pkgver/libQuotient-$pkgver.tar.gz"
+options="!check" # Requires a running homeserver
+builddir="$srcdir/libQuotient-$pkgver"
build() {
cmake -B build \
@@ -22,11 +21,18 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DQuotient_ENABLE_E2EE=True
- make -C build
+ cmake --build build
+ cmake tests -B build-test
+ cmake --build build-test
+}
+
+check() {
+ cd build-test
+ ./quotest # <username> <password> quotest-travis '#quotest:matrix.org' "Alpine Linux CI"
}
package() {
- DESTDIR="$pkgdir" make -C build install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="f812a230f969113f14b95df534002a1ce3957b90045197ed7789679bd92fd583b700436f8063f7bbc596bd962ff70e2b72a7f8ded7096f78e4ebc6e9559af10c libQuotient-58dfe74390ebdd8ec6611d3b8fecfe7d051ff955.tar.gz"
+sha512sums="42f7d1ee788cc2bd9d88f0ec4339573d1c4be85c462ddb81d4b4cc222fa46d3482bf4c231fd8c35f334aefa112f45251239a99c37456efcae0ca5d9359271f72 libQuotient-0.6.0.tar.gz"