aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-08-19 19:25:33 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-09-21 23:36:15 +0000
commit4bd419eef70657b10dbf8657a4435a0117c9c394 (patch)
treedd77f8c70b3d5b896c49463640bc3da10971da55
parent45f630cedbe3066dd7734ff8d18282ec1edc0a50 (diff)
testing/perl-toml: new aport
-rw-r--r--testing/perl-toml/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/perl-toml/APKBUILD b/testing/perl-toml/APKBUILD
new file mode 100644
index 00000000000..ece44bb01d7
--- /dev/null
+++ b/testing/perl-toml/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-toml
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=TOML
+pkgver=0.97
+pkgrel=0
+pkgdesc="Parser for Tom's Obvious, Minimal Language."
+url="https://metacpan.org/release/TOML/"
+arch="noarch"
+license="GPL-2.0-only"
+depends="perl perl-toml-parser"
+makedepends="perl-dev perl-module-build-tiny perl-module-build"
+checkdepends="perl-common-sense"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/K/KA/KARUPA/TOML-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="96eb23e6f889119b67579340b48ed4ff089bd6600aab0d06954516a95a5017f3c042f25c9df5957312c770e39206fe03e758262e7efc0bffebb183e6287cdfb4 TOML-0.97.tar.gz"