aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 13:21:51 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-12 13:21:53 +0000
commit4cee145dc41b63db6b2ca7c24a65118af116b971 (patch)
tree36eb4d19755281aecb032e971bd71df46f26a441
parent3039b7460d922d8998cfd56520441e099ef170df (diff)
community/sent: add check function
As upstream doesn't provide a suite test, run -version to test if the binary actually works.
-rw-r--r--community/sent/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/sent/APKBUILD b/community/sent/APKBUILD
index 9be245b7a9c..f147b91b2c7 100644
--- a/community/sent/APKBUILD
+++ b/community/sent/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=sent
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple plaintext presentation tool"
url="http://tools.suckless.org/sent/"
arch="all"
@@ -12,7 +12,6 @@ depends_dev=""
makedepends="libx11-dev libxft-dev"
install=""
subpackages="$pkgname-doc"
-options="!check" # upstream doesn't have a test suite
source="http://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz
config-mk.patch"
builddir="$srcdir"
@@ -22,6 +21,11 @@ build() {
make -C "$builddir"
}
+check() {
+ cd "$builddir"
+ ./sent -version > /dev/null
+}
+
package() {
cd "$builddir"
make PREFIX="/usr" DESTDIR="$pkgdir" \