aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2021-04-25 21:39:38 +0200
committerMichał Polański <michal@polanski.me>2021-04-25 22:15:04 +0200
commit4e84d3cc6078623b0436526c339fd177a1804fb8 (patch)
tree17fbae7e3c6d11dd3d4da4dbdb6f36d075742af9
parent7e52bff23671c0cdad2d58cbbcb8244626560f8e (diff)
community/seatd: use a dedicated group
Users with "video" group membership can open video devices directly, effectively bypassing the seat manager.
-rw-r--r--community/seatd/APKBUILD6
-rw-r--r--community/seatd/seatd.initd2
-rw-r--r--community/seatd/seatd.pre-install5
3 files changed, 10 insertions, 3 deletions
diff --git a/community/seatd/APKBUILD b/community/seatd/APKBUILD
index 6e5af00c135..3b12a8aa606 100644
--- a/community/seatd/APKBUILD
+++ b/community/seatd/APKBUILD
@@ -2,11 +2,13 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=seatd
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Minimal seat management daemon"
url="https://sr.ht/~kennylevinsen/seatd/"
arch="all !ppc64le !mips64" # build failure
license="MIT"
+pkggroups="seat"
+install="$pkgname.pre-install"
makedepends="meson scdoc elogind-dev linux-headers"
subpackages="libseat:libs libseat-dev $pkgname-doc $pkgname-openrc"
source="
@@ -43,4 +45,4 @@ dev() {
}
sha512sums="a6b1f11313411fe99e8bdd64aa493fc19bde7b0b927f21e2c3ec8a7fadc6cf2f04fcefa73fa033d971d1dc482665d3dc927ec168026289fe88b2593a45adbc0f seatd-0.5.0.tar.gz
-fdd8128d259974a227eacb9bcb7251dac83b10700a7b75848059f36878cf405e9be956ab6fbd0ef08b425476c8c456a52f7d2082e2015e7c0a3fdb8220051ffb seatd.initd"
+425e0249d1328ccef6502b1e0b8c8277bd3905fcccdabde0e497189db449b910d0b1956cf6e7c7a24991f30b2f41af8ffde490342c53ba161b26525320ae9607 seatd.initd"
diff --git a/community/seatd/seatd.initd b/community/seatd/seatd.initd
index 23eeb2a773d..999c0bd6750 100644
--- a/community/seatd/seatd.initd
+++ b/community/seatd/seatd.initd
@@ -5,6 +5,6 @@ name=$RC_SVCNAME
description="Seat management daemon"
command="seatd"
-command_args="-g video"
+command_args="-g seat"
supervise_daemon_args="--stderr /var/log/seatd.log"
diff --git a/community/seatd/seatd.pre-install b/community/seatd/seatd.pre-install
new file mode 100644
index 00000000000..04f11848518
--- /dev/null
+++ b/community/seatd/seatd.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+addgroup -S seat 2>/dev/null
+
+exit 0