aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2020-06-26 00:27:19 +0300
committerAndy Postnikov <apostnikov@gmail.com>2020-07-04 14:55:40 +0000
commit4f917d4b3878271cdc83972bb3432bf4696c6bce (patch)
tree1cf3cce24593a2928dc3eb9c8a84a4c33e29f11f
parent29762891304302bf0756711796d2cca06ffb4616 (diff)
community/cpputest: upgrade to 4.0
* Patch is now upstream, remove. * Split static subpackage.
-rw-r--r--community/cpputest/APKBUILD15
-rw-r--r--community/cpputest/test-s390x.patch17
2 files changed, 7 insertions, 25 deletions
diff --git a/community/cpputest/APKBUILD b/community/cpputest/APKBUILD
index ece82e4f318..1857e3be3ed 100644
--- a/community/cpputest/APKBUILD
+++ b/community/cpputest/APKBUILD
@@ -1,22 +1,22 @@
# Contributor: Shiva Velmurugan <shiv@shiv.me>
# Maintainer: Shiva Velmurugan <shiv@shiv.me>
pkgname=cpputest
-pkgver=3.8
-pkgrel=2
+pkgver=4.0
+pkgrel=0
pkgdesc="A unit testing and mocking framework for C/C++"
url="http://cpputest.github.io/"
arch="all !mips !mips64" # FTBFS on soft-float (mips)
license="BSD-3-Clause"
options="!dbg"
makedepends="cmake"
-source="https://github.com/cpputest/cpputest/releases/download/v$pkgver/cpputest-$pkgver.tar.gz
- test-s390x.patch
- "
+subpackages="$pkgname-static"
+source="https://github.com/cpputest/cpputest/releases/download/v$pkgver/cpputest-$pkgver.tar.gz"
build() {
cmake -B build . \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
make -C build
}
@@ -33,5 +33,4 @@ package() {
rmdir "$pkgdir"/usr/lib/CppUTest
}
-sha512sums="a9592bdc9ffab8b42026ef2010f504e7e37d77fc2f197f89d23f7c9285a101059a0ec66418b914db0383974616d31b26addd1938fb27f45c3e7d9496ed0a0fac cpputest-3.8.tar.gz
-dd1366d9d692c74d1581590992f1ce927a566f9bdcf520d3097330d986d5b9c32b26cac1a2672a3eab4856350117a1e3af05e2ff4122aa11ae21434b0822d978 test-s390x.patch"
+sha512sums="69f39fffdcd965c871e598118db38ddb74a3e75fd7a7965f8d236029fa891f6fcb6b671147c166ad08482bbd0737537fafe90aa8439a0ab62389f19150cc39d7 cpputest-4.0.tar.gz"
diff --git a/community/cpputest/test-s390x.patch b/community/cpputest/test-s390x.patch
deleted file mode 100644
index 13175112630..00000000000
--- a/community/cpputest/test-s390x.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-ref https://github.com/cpputest/cpputest/issues/1004
-
-diff --git a/tests/CppUTestExt/MockSupport_cTest.cpp b/tests/CppUTestExt/MockSupport_cTest.cpp
-index 8fc55ec..5188857 100644
---- a/tests/CppUTestExt/MockSupport_cTest.cpp
-+++ b/tests/CppUTestExt/MockSupport_cTest.cpp
-@@ -186,8 +186,8 @@ TEST(MockSupport_c, outputParameters_differentType)
-
- TEST(MockSupport_c, outputParametersOfType)
- {
-- long param = 1;
-- const long retval = 2;
-+ int param = 1;
-+ const int retval = 2;
- mock_c()->installCopier("typeName", typeCopy);
- mock_c()->expectOneCall("foo")->withOutputParameterOfTypeReturning("typeName", "out", &retval);
- mock_c()->actualCall("foo")->withOutputParameterOfType("typeName", "out", &param);