aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-08-19 23:34:55 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-09-21 23:36:21 +0000
commit5026a5c7d73bec4da7bca8f0654c27c1c9d2b8d0 (patch)
tree00d2dfbd710e3bb753ac2e0b52b23f2158158fdb
parentf317f3355fa098accf69f2cd2a762e203d7426f9 (diff)
testing/perl-exception-tiny: new aport
-rw-r--r--testing/perl-exception-tiny/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/perl-exception-tiny/APKBUILD b/testing/perl-exception-tiny/APKBUILD
new file mode 100644
index 00000000000..cbfb9496ff5
--- /dev/null
+++ b/testing/perl-exception-tiny/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-exception-tiny
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Exception-Tiny
+pkgver=0.2.1
+pkgrel=0
+pkgdesc="Perl module for Exception-Tiny"
+url="https://metacpan.org/release/Exception-Tiny/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev perl-class-accessor-lite perl-module-build perl-test-requires"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/Y/YA/YAPPO/Exception-Tiny-v0.2.1.tar.gz"
+builddir="$srcdir/$_pkgreal-v$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ ./Build test
+}
+
+package() {
+ ./Build install --destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="c72d3b576ecf022ff00e31e37fe2259724df908b6a09ea8310baa70aedd8a5779c3b5a180ade5ef25456280184b638c12585b408be5320545d0bbed6684338c1 Exception-Tiny-v0.2.1.tar.gz"