aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoni Aloy Torrens <aaloytorrens@gmail.com>2021-02-12 14:01:03 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-03-21 07:10:44 +0000
commit50940e9e69f837507d45e3ebc473182d83abd7d1 (patch)
treed9a0903afa917869a6dc139b79ab76269cb042a7
parent07745a7437a9c1817a17db8f11c01f697eda3b4d (diff)
testing/libsysstat: new aport
-rw-r--r--testing/libsysstat/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/libsysstat/APKBUILD b/testing/libsysstat/APKBUILD
new file mode 100644
index 00000000000..d9438cafa31
--- /dev/null
+++ b/testing/libsysstat/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=libsysstat
+pkgver=0.4.4
+pkgrel=0
+pkgdesc="Library used to query system info and statistics"
+url="https://github.com/lxqt/libsysstat"
+arch="all"
+license="LGPL-2.1-or-later"
+subpackages="$pkgname-dev"
+makedepends="lxqt-build-tools cmake qt5-qtbase-dev"
+options="!check" # No testsuite
+source="https://github.com/lxqt/libsysstat/releases/download/$pkgver/libsysstat-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+
+sha512sums="2d3545f6b3872dd48f9d4537352e6f8884cf10adca71625f75da7898a71c3100df996b6a3f8cd851d352347db5b82c67402172831179c574639c75dd35ed1d88 libsysstat-0.4.4.tar.xz"