aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-05-20 20:55:58 -0400
committerLeo <thinkabit.ukim@gmail.com>2020-05-21 07:28:25 +0000
commit525d6432c442f608344a0a776a36beeb4b87fcda (patch)
treeae4185c7d9301221a7786f20fdd10697d7745d6a
parent1cbba9929ad292c86c3d58c6f02c0f1fb92e421f (diff)
testing/tuir: new aport
https://gitlab.com/ajak/tuir Terminal UI for Reddit testing/
-rw-r--r--testing/tuir/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/tuir/APKBUILD b/testing/tuir/APKBUILD
new file mode 100644
index 00000000000..e32d0a0b093
--- /dev/null
+++ b/testing/tuir/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=tuir
+pkgver=1.29.0
+pkgrel=0
+pkgdesc="Terminal UI for Reddit"
+url="https://gitlab.com/ajak/tuir"
+arch="noarch"
+license="MIT"
+depends="python3 py3-decorator py3-beautifulsoup4 py3-kitchen py3-six py3-requests"
+options="!check" # tests fail
+makedepends="py3-setuptools"
+subpackages="$pkgname-doc"
+source="https://files.pythonhosted.org/packages/source/t/tuir/tuir-$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ea7a531c8116d4a1fc6f209a80833289c366ed34811e7d74c977d10a658761e7ef6b6a890f46cfe0089e9176cfb63a25856128937be34bd05d529c8168dd26b4 tuir-1.29.0.tar.gz"