aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-06-21 17:18:10 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-21 17:16:28 +0000
commit5282a3d62615a06c315ea1b304834b906dd2c8d0 (patch)
tree46d6fc26ee61b8f5a40f767883c299e1b3deb553
parent8e8445e9d6a4034563dc1bb61aa016703c4b7dfd (diff)
testing/py3-pastel: do not install the tests package
-rw-r--r--testing/py3-pastel/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/py3-pastel/APKBUILD b/testing/py3-pastel/APKBUILD
index c315cd6a3a6..1eed1f80aef 100644
--- a/testing/py3-pastel/APKBUILD
+++ b/testing/py3-pastel/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-pastel
_realname=pastel
pkgver=0.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Python3 library to bring colors to your terminal"
options="!check" # No testsuite on tarball with setup.py
url="https://github.com/sdispater/pastel"
@@ -11,7 +11,7 @@ arch="noarch"
license="MIT"
depends="python3"
makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/${_realname:0:1}/$_realname/$_realname-$pkgver.tar.gz"
+source="https://pypi.io/packages/source/p/pastel/pastel-$pkgver.tar.gz"
builddir="$srcdir/$_realname-$pkgver"
build() {
@@ -20,6 +20,10 @@ build() {
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ # do not install the tests package
+ # see: https://github.com/sdispater/pastel/issues/7
+ rm -r "$pkgdir"/usr/lib/python*/site-packages/tests
}
-sha512sums="1a65e1ec919ce4a216310c9c2c7529b00c6b49d37eda082b1269c3d6298f2f14a1ecca8c427c7487f73478add171abb34359c0fa7a20a956d475ab17070bf697 py3-pastel-0.2.0.tar.gz"
+sha512sums="1a65e1ec919ce4a216310c9c2c7529b00c6b49d37eda082b1269c3d6298f2f14a1ecca8c427c7487f73478add171abb34359c0fa7a20a956d475ab17070bf697 pastel-0.2.0.tar.gz"