aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-04-05 12:40:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:28 +0000
commit53a2ede7c4814fc1d6bcf1307cf88dd1a48a016d (patch)
treef3c1084b4b41248d92e9e5c40110e7d799edba8c
parentcd22a966404dbef8aec3d78c838904a11137a7f1 (diff)
main/gstreamer, main/gst-plugins-[base,good,bad,ugly]
main/gstreamer: Clarify license main/gst-plugins-base: Clarify license, update configure options main/gst-plugins-good: Clarify license, update configure options, add Qt and Gtk-3 plugins as separate packages main/gst-plugins-bad: Clarify license, updte configure options, fix compile against libressl main/gst-plugins-ugly: Clarify license, updte configure options
-rw-r--r--main/gst-plugins-bad/APKBUILD23
-rw-r--r--main/gst-plugins-bad/libressl270-dtsl_method.patch18
-rw-r--r--main/gst-plugins-base/APKBUILD5
-rw-r--r--main/gst-plugins-good/APKBUILD61
-rw-r--r--main/gst-plugins-ugly/APKBUILD17
-rw-r--r--main/gstreamer/APKBUILD2
6 files changed, 85 insertions, 41 deletions
diff --git a/main/gst-plugins-bad/APKBUILD b/main/gst-plugins-bad/APKBUILD
index 2a38ab9ebc0..dad3051d843 100644
--- a/main/gst-plugins-bad/APKBUILD
+++ b/main/gst-plugins-bad/APKBUILD
@@ -5,8 +5,7 @@ pkgrel=0
pkgdesc="GStreamer bad plugins"
url="https://gstreamer.freedesktop.org/"
arch="all"
-license="LGPL GPL"
-depends=""
+license="GPL-2.0-or-later LGPL-2.0-or-later"
replaces="gst-plugins-bad1"
options="!check" # most fail because: XDG_RUNTIME_DIR not set in the env.
makedepends="
@@ -22,30 +21,30 @@ makedepends="
gsm-dev
gst-plugins-base-dev
gstreamer-dev
- jasper-dev
libdc1394-dev
libexif-dev
libmms-dev
libmodplug-dev
liboil-dev
- libressl-dev
+ libressl-dev>=2.7.0
librsvg-dev
libvdpau-dev
libx11-dev
mesa-dev
neon-dev
orc-dev
- sdl2-dev
+ directfb-dev
spandsp-dev
libwebp-dev
x265-dev
- xvidcore-dev
+ libass-dev
+ libsrtp-dev
+ orc-compiler
"
-checkdepends="orc-compiler"
subpackages="$pkgname-lang $pkgname-dev $pkgname-doc"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
-ldpath="/usr/lib/gstreamer-.0"
-builddir="$srcdir"/gst-plugins-bad-$pkgver
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz
+ libressl270-dtsl_method.patch"
+ldpath="/usr/lib/gstreamer-1.0"
build() {
cd "$builddir"
@@ -77,5 +76,5 @@ doc() {
default_doc
replaces="${pkgname}1-doc"
}
-
-sha512sums="3f64dc428e2c1890f05d2c718215ff4b78a8262255ea61e746b436dc9ce1d3e0671db9cf3640f9a7453434297cac3a134272de7785818dfc5a6011ce8584842f gst-plugins-bad-1.14.0.tar.xz"
+sha512sums="3f64dc428e2c1890f05d2c718215ff4b78a8262255ea61e746b436dc9ce1d3e0671db9cf3640f9a7453434297cac3a134272de7785818dfc5a6011ce8584842f gst-plugins-bad-1.14.0.tar.xz
+82106a8fa7ac01c63c3298c33a3b6177a4115f380d475634ea8ba4c67654f96275ab4b35eb4ea712a997165fefa7e9b65fd6b14ed3cea478c200d7e8d61423c4 libressl270-dtsl_method.patch"
diff --git a/main/gst-plugins-bad/libressl270-dtsl_method.patch b/main/gst-plugins-bad/libressl270-dtsl_method.patch
new file mode 100644
index 00000000000..6ea60851802
--- /dev/null
+++ b/main/gst-plugins-bad/libressl270-dtsl_method.patch
@@ -0,0 +1,18 @@
+--- a/ext/dtls/gstdtlsagent.c
++++ b/ext/dtls/gstdtlsagent.c
+@@ -176,11 +176,11 @@
+
+ ERR_clear_error ();
+
+-#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
+- priv->ssl_context = SSL_CTX_new (DTLS_method ());
+-#else
++//#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
++ // priv->ssl_context = SSL_CTX_new (DTLS_method ());
++//#else
+ priv->ssl_context = SSL_CTX_new (DTLSv1_method ());
+-#endif
++//#endif
+ if (ERR_peek_error () || !priv->ssl_context) {
+ char buf[512];
+
diff --git a/main/gst-plugins-base/APKBUILD b/main/gst-plugins-base/APKBUILD
index a8e338e7e23..5cff3cc256a 100644
--- a/main/gst-plugins-base/APKBUILD
+++ b/main/gst-plugins-base/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=0
pkgdesc="GStreamer Multimedia Framework Base Plugins"
url="https://gstreamer.freedesktop.org/"
arch="all"
-license="GPL LGPL"
+license="GPL-2.0-or-later LGPL-2.0-or-later"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
depends=
replaces="gst-plugins-base1"
@@ -27,8 +27,9 @@ makedepends="
gstreamer-dev
glib-dev
opus-dev
+ mesa-dev
+ orc-compiler
"
-checkdepends="orc-compiler"
source="https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-$pkgver.tar.xz"
ldpath="/usr/lib/gstreamer-1.0"
builddir="$srcdir"/gst-plugins-base-$pkgver
diff --git a/main/gst-plugins-good/APKBUILD b/main/gst-plugins-good/APKBUILD
index e6900436e0f..443dd00a78c 100644
--- a/main/gst-plugins-good/APKBUILD
+++ b/main/gst-plugins-good/APKBUILD
@@ -5,12 +5,12 @@ pkgrel=0
pkgdesc="GStreamer Multimedia Framework Good Plugins"
url="https://gstreamer.freedesktop.org/"
arch="all"
-license="LGPL"
-subpackages="$pkgname-lang $pkgname-doc"
-depends=
+license="GPL-2.0-or-later LGPL-2.0-or-later"
+subpackages="$pkgname-lang $pkgname-doc $pkgname-qt $pkgname-gtk"
replaces="gst-plugins-good1"
-depends_dev="gstreamer-dev gst-plugins-base-dev"
-makedepends="$depends_dev
+makedepends="
+ gstreamer-dev
+ gst-plugins-base-dev
flac-dev
gdk-pixbuf-dev
glib-dev
@@ -37,12 +37,18 @@ makedepends="$depends_dev
v4l-utils-dev
wavpack-dev
zlib-dev
+ mpg123-dev
+ lame-dev
+ gtk+3.0-dev
+ qt5-qtdeclarative-dev
+ qt5-x11extras-dev
+ libcaca-dev
+ cairo-dev
+ orc-compiler
"
-replaces=
-ldpath="/usr/lib/gstreamer-.0"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
- "
-builddir="$srcdir"/gst-plugins-good-$pkgver
+ldpath="/usr/lib/gstreamer-1.0"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz"
+options="!check" # elements/souphttpsrc fails
# secfixes:
# 1.10.4-r0:
@@ -57,7 +63,7 @@ builddir="$srcdir"/gst-plugins-good-$pkgver
# - CVE-2016-10199
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -68,15 +74,42 @@ build() {
--enable-experimental \
--disable-fatal-warnings \
--with-package-name="GStreamer Good Plugins (Alpine Linux)" \
- --with-package-origin="http://alpinelinux.org/" \
- || return 1
+ --with-package-origin="http://alpinelinux.org/"
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+_mv() {
+ mkdir -p "$subpkgdir"/"$ldpath"
+ mv "$1" "$subpkgdir"/"$ldpath"
+}
+
+qt() {
+ pkgdesc="Gstreamer Qt plugin."
+ for i in $(find "$pkgdir" -type f ); do
+ if ldd $i 2>/dev/null | grep -q "libQt"; then
+ _mv "$i" || return 1
+ fi
+ done
+}
+
+gtk() {
+ pkgdesc="Gstreamer gtk-3 plugin."
+ for i in $(find "$pkgdir" -type f ); do
+ if ldd $i 2>/dev/null | grep -q "libgtk-3"; then
+ _mv "$i" || return 1
+ fi
+ done
}
doc() {
diff --git a/main/gst-plugins-ugly/APKBUILD b/main/gst-plugins-ugly/APKBUILD
index 273d209834c..a30b6185d4d 100644
--- a/main/gst-plugins-ugly/APKBUILD
+++ b/main/gst-plugins-ugly/APKBUILD
@@ -5,28 +5,23 @@ pkgrel=0
pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
url="https://gstreamer.freedesktop.org/"
arch="all"
-license="LGPL"
-depends=
+license="GPL-2.0-or-later LGPL-2.0-or-later"
replaces="gst-plugins-ugly1"
makedepends="
a52dec-dev
glib-dev
gst-plugins-base-dev
gstreamer-dev
- lame-dev
libcdio-dev
libdvdread-dev
- libid3tag-dev
libmpeg2-dev
liboil-dev
- mpg123-dev
orc-dev
x264-dev
"
source="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-ldpath="/usr/lib/gstreamer-.0"
-builddir="$srcdir"/gst-plugins-ugly-$pkgver
+ldpath="/usr/lib/gstreamer-1.0"
# secfixes:
# 1.10.4-r0:
@@ -46,13 +41,11 @@ build() {
--enable-a52dec \
--enable-cdio \
--enable-dvdread \
- --enable-lame \
--enable-mpeg2dec \
- --enable-mpg123 \
+ --enable-x264 \
--disable-fatal-warnings \
--with-package-name="GStreamer Ugly Plugins (Alpine Linux)" \
- --with-package-origin="http://alpinelinux.org/" \
- || return 1
+ --with-package-origin="http://alpinelinux.org/"
make
}
@@ -63,7 +56,7 @@ check() {
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
doc() {
diff --git a/main/gstreamer/APKBUILD b/main/gstreamer/APKBUILD
index 32ea14f00d9..ff016a3c5ba 100644
--- a/main/gstreamer/APKBUILD
+++ b/main/gstreamer/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=0
pkgdesc="GStreamer Multimedia Framework"
url="https://gstreamer.freedesktop.org/"
arch="all"
-license="LGPL-2.0+"
+license="LGPL-2.0-or-later"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools $pkgname-lang"
replaces="gstreamer1"
depends_dev="libxml2-dev"