aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-09-06 10:32:06 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-09-07 07:58:51 +0000
commit55018d4a38cf88588db244133dce56de10223736 (patch)
tree2fe45a9033ec375c8e43d60db27250a9a3b0bca1
parentf55713fe93e77be07bd5b9cb7d02dc19584bec29 (diff)
main/libdnet: modernize
-rw-r--r--main/libdnet/APKBUILD33
1 files changed, 11 insertions, 22 deletions
diff --git a/main/libdnet/APKBUILD b/main/libdnet/APKBUILD
index 85fe1189a80..8d6324a3787 100644
--- a/main/libdnet/APKBUILD
+++ b/main/libdnet/APKBUILD
@@ -7,46 +7,35 @@ url="https://github.com/dugsong/libdnet"
arch="all"
license="BSD"
subpackages="$pkgname-dev $pkgname-doc"
-depends=""
makedepends="autoconf automake bash libtool linux-headers"
-install=
-source="https://github.com/dugsong/libdnet/archive/libdnet-1.12.tar.gz
- automake.patch"
+source="https://github.com/dugsong/libdnet/archive/$pkgname-$pkgver.tar.gz
+ automake.patch
+ "
-_builddir="$srcdir"/$pkgname-$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgname-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
# the libtool script does not add .so extention to we generate
# new libtool
aclocal -I config && autoconf && automake --force --add-missing \
- && libtoolize || return 1
+ && libtoolize
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
- --without-python \
- || return 1
- make || return 1
+ --without-python
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="d2f1b72eac2a1070959667e9e61dcf20 libdnet-1.12.tar.gz
-059d1e50cfa27cab45af72530a4f74fd automake.patch"
-sha256sums="b6360659c93fa2e3cde9e0a1fc9c07bc4111f3448c5de856e095eb98315dd424 libdnet-1.12.tar.gz
-d29bcb810a722a961fc96793e07fb759c83c375415926802e732c8e4c06ca693 automake.patch"
sha512sums="a2410a98b76d4bccecf7bcb82ff0b6e9fb809b389f7fea938cc42d94e18622cc5f353d2de737121a1990d9e16e9db8cc2f82677c94f78cd03c9227e815eab9e0 libdnet-1.12.tar.gz
8a47795c5edb5f67df46a59f2f4d8798b2e34f34e0aae3202a6cca8e475f105e08fa5586a432fba9f443c1df57441cffcdc08f5e4eb53df8e73c2a6c8c075477 automake.patch"