aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTuan Hoang <tmhoang@linux.ibm.com>2019-11-22 19:10:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-25 07:29:21 +0000
commit551ef01daa31dc21f85c084aaeb40fd51b3163bf (patch)
tree34571e8ccb2c0d04d4d59538b2c5cc9e13415e37
parent3228be102f0d913844aa54c37d4186d1a3aafd2a (diff)
community/cloudi,dune,haxe,opam: enable s390x
-rw-r--r--community/cloudi/APKBUILD2
-rw-r--r--community/dune/APKBUILD2
-rw-r--r--community/haxe/APKBUILD2
-rw-r--r--community/opam/APKBUILD2
4 files changed, 4 insertions, 4 deletions
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index 1c8c66b1d33..ddb580e9647 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -83,7 +83,7 @@ builddir="$srcdir/cloudi-$pkgver"
CONFIGURE_ARGS=""
# Enable OCaml on the appropriate architectures
case "$CTARGET_ARCH" in
-x86 | armhf | armv7 | s390x)
+x86 | armhf | armv7)
;;
*)
makedepends="$makedepends ocaml"
diff --git a/community/dune/APKBUILD b/community/dune/APKBUILD
index 16e73b5f9a1..489a0217ede 100644
--- a/community/dune/APKBUILD
+++ b/community/dune/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.10.0
pkgrel=0
pkgdesc="A composable build system for OCaml (formerly Jbuilder)"
url="https://github.com/ocaml/dune"
-arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml abuild
+arch="all !x86 !armhf !armv7" # limited by ocaml abuild
license="Apache-2.0"
checkdepends="bash"
makedepends="ocaml ocaml-compiler-libs ocaml-findlib-dev"
diff --git a/community/haxe/APKBUILD b/community/haxe/APKBUILD
index feaf6f299df..79baef91cc9 100644
--- a/community/haxe/APKBUILD
+++ b/community/haxe/APKBUILD
@@ -6,7 +6,7 @@ _versuffix=
pkgrel=1
pkgdesc="Cross-platform toolkit and programming language"
url="https://haxe.org"
-arch="x86_64 aarch64 ppc64le"
+arch="all !x86 !armhf !armv7"
license="GPL MIT LGPL" # http://haxe.org/foundation/open-source.html
makedepends="ocaml-camlp4-dev ocaml neko-dev zlib-dev pcre-dev"
options="!strip"
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 85552432707..9fc68ba8628 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.0.5
pkgrel=0
pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
-arch="all !x86 !armhf !armv7 !s390x" # ocaml not avail on excluded platforms
+arch="all !x86 !armhf !armv7" # ocaml not avail on excluded platforms
license="LGPL-2.1"
depends="ocaml curl xz tar unzip rsync patch bubblewrap bash"
makedepends="ocaml-compiler-libs"