aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2020-05-15 15:45:20 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-06-05 14:21:28 +0000
commit556709557784dff0bdb1f89dfeb4614d7c5c07b4 (patch)
tree8e08bbc6ee23a3d83e649efed83ff7a4f25f6229
parent12cbb6719eb6dca26caf25f41e68885230a1d203 (diff)
testing/libfyaml: new aport
https://github.com/pantoniou/libfyaml Fully feature complete YAML parser and emitter.
-rw-r--r--testing/libfyaml/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/libfyaml/APKBUILD b/testing/libfyaml/APKBUILD
new file mode 100644
index 00000000000..462449e1c21
--- /dev/null
+++ b/testing/libfyaml/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
+# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
+pkgname=libfyaml
+pkgver=0.5.7
+pkgrel=0
+pkgdesc="Fully feature complete YAML parser and emitter"
+url="https://github.com/pantoniou/libfyaml"
+arch="all"
+license="MIT"
+depends="libltdl"
+checkdepends="check git"
+makedepends="autoconf automake bash libtool"
+subpackages="$pkgname-dev"
+source="https://github.com/pantoniou/libfyaml/releases/download/v$pkgver/libfyaml-$pkgver.tar.gz"
+options="!check" # tests failing, (See: https://github.com/pantoniou/libfyaml/issues/20)
+
+prepare() {
+ default_prepare
+ ./bootstrap.sh
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ make check
+}
+
+sha512sums="ccdd47cdc1703d18a3aee362b3acbc6a3f98fbb65032544231a05eb944a8d9a6e160b6411a2db0f50e4f70f44e4aa368f1df15a7980ce5480be59dd99e9c58b8 libfyaml-0.5.7.tar.gz"