aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-13 17:29:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-13 20:56:26 +0000
commit557f87e820164c62af87d076accf598b2038516c (patch)
tree61503691e7da01aa37d8208447cf4288813d18aa
parent28eb843597686b378e9e0ecebfffbb98e7374b49 (diff)
community/pangomm: upgrade to 2.42.2
-rw-r--r--community/pangomm/APKBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/community/pangomm/APKBUILD b/community/pangomm/APKBUILD
index b5635c40426..d670c66a706 100644
--- a/community/pangomm/APKBUILD
+++ b/community/pangomm/APKBUILD
@@ -2,27 +2,24 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=pangomm
-pkgver=2.42.1
+pkgver=2.42.2
pkgrel=0
pkgdesc="C++ bindings for pango"
+options="!check" # No testsuite
url="https://www.gtkmm.org/"
arch="all"
license="LGPL-2.1-or-later AND GPL-2.0-or-later"
-makedepends="pango-dev glibmm-dev cairomm-dev"
-options="!check" # no tests
+makedepends="meson pango-dev glibmm-dev cairomm-dev"
subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/pangomm/${pkgver%.*}/pangomm-$pkgver.tar.xz"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr
- make
+ abuild-meson . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="46ba375e61dd32e268397ecb8e69364b642ea3d9a6c4d9e3e52500e1e1c9fa0c6aa822c6d5046f49a2fe4d9a872c6c2b354134d39c17370abcfc6a1d752223b0 pangomm-2.42.1.tar.xz"
+sha512sums="5e4826d64c0178527b4df73e901d2fdf5661d41777e189f5e2d4b26577e42689efaccf5a28502246c6b3926571ccd5876cb23d33267b44ace7ee164322c14667 pangomm-2.42.2.tar.xz"