aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Truog <mjtruog@protonmail.com>2020-06-06 16:08:01 -0700
committerLeo <thinkabit.ukim@gmail.com>2020-06-07 01:42:38 +0000
commit55e76990ca89be48c8a9da0f70eef3cdbadd92c5 (patch)
tree431cac5ee5e1972ee8056401e76c16b85b3c3d21
parentfaf1e3b0ba0619b0bad9b11750be9dbac5017458 (diff)
community/cloudi: Upgrade to 2.0.0
* 0005-Disable-tests-for-aports-buildservers.patch is no longer necessary * erlang-23.patch is no longer necessary * fix-new-binutils.patch is no longer necessary
-rw-r--r--community/cloudi/0005-Disable-tests-for-aports-buildservers.patch21
-rw-r--r--community/cloudi/APKBUILD33
-rw-r--r--community/cloudi/erlang-23.patch252
-rw-r--r--community/cloudi/fix-new-binutils.patch20
4 files changed, 10 insertions, 316 deletions
diff --git a/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch b/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
deleted file mode 100644
index 7287b95ba1a..00000000000
--- a/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./src/rebar_src_test.config.in
-+++ ./src/rebar_src_test.config.in
-@@ -9,8 +9,6 @@
- "lib/cloudi_service_api_batch",
- "lib/cloudi_service_api_requests",
- "lib/cloudi_service_cron",
-- "lib/cloudi_service_db_mysql",
-- "lib/cloudi_service_db_pgsql",
- "lib/cloudi_service_filesystem",
- "lib/cloudi_service_http_client",
- "lib/cloudi_service_http_cowboy1",
-@@ -19,9 +17,7 @@
- "lib/cloudi_service_map_reduce",
- "lib/cloudi_service_monitoring",
- "lib/cloudi_service_null",
-- "lib/cloudi_service_oauth1",
- "lib/cloudi_service_queue",
-- "lib/cloudi_service_quorum",
- "lib/cloudi_service_request_rate",
- "lib/cloudi_service_router",
- "lib/cloudi_service_shell",
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index 33e0f4834d6..b54156578f5 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -28,8 +28,8 @@
# (shown below with the assignment of CLOUDI_PID_FILE).
pkgname=cloudi
-pkgver=1.8.0
-pkgrel=7
+pkgver=2.0.0
+pkgrel=0
pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
url="https://cloudi.org/"
license="MIT"
@@ -55,12 +55,8 @@ makedepends="autoconf
python3-dev
ruby
"
-options="!check" # performance test issues
subpackages="$pkgname-static $pkgname-openrc"
source="https://osdn.net/dl/cloudi/cloudi-$pkgver.tar.gz
- 0005-Disable-tests-for-aports-buildservers.patch
- fix-new-binutils.patch
- erlang-23.patch
$pkgname.initd"
@@ -68,24 +64,18 @@ source="https://osdn.net/dl/cloudi/cloudi-$pkgver.tar.gz
# Enable OCaml on the appropriate architectures
case "$CTARGET_ARCH" in
-armhf | armv7 | mips*)
- ;;
-x86)
- # 4 tests out of 7 fail due to 'timetrap_timeout'
- options="$options !check"
- ;;
-*)
- makedepends="$makedepends ocaml"
- _configure_args="$_configure_args --enable-ocaml-support"
- ;;
+ x86 | arm* | mips*)
+ ;;
+ *)
+ makedepends="$makedepends ocaml"
+ _configure_args="$_configure_args --enable-ocaml-support"
+ ;;
esac
# Enable Haskell on the appropriate architectures
case "$CTARGET_ARCH" in
x86_64)
makedepends="$makedepends ghc cabal zlib-dev"
_configure_args="$_configure_args --enable-haskell-support"
- # 1 test out of 7 fail due to 'timetrap_timeout'
- #options="$options !check"
;;
esac
@@ -107,8 +97,8 @@ build() {
--infodir=/usr/share/info \
--host="$CHOST" \
--build="$CBUILD" \
+ --with-test-timeout=600 \
--with-cxx-backtrace \
- --with-python-version=3 \
--enable-go-support $_configure_args
make
}
@@ -125,8 +115,5 @@ package() {
"$pkgdir"/etc/init.d/$pkgname
}
-sha512sums="53a99729fa37673cfcc7fb7e76e285ff7bd978a080a65d46259b53c6dd0854214ee91b0e93f090d6958045f7e1eb0b739fcfc13c86070780f518f48bd9732fc8 cloudi-1.8.0.tar.gz
-8b3c67ce0899b64b9f48da749864b95e3d9747383c1daabdad7e6230ebb815329ccbdc7f69a956590ddda0a32ff74d073f98bdc0b15d5dc4728dd11640835a6c 0005-Disable-tests-for-aports-buildservers.patch
-4808b481b5e96db7534fd856ea17754cf3efaa4d07dec3bcba1e760e979307010262c5aed40a9b12f1bbddbf37201be6d8b6af4715639c76fc515e8bac562189 fix-new-binutils.patch
-33995595c044e21737a17bdc9270e5b6b0dd49ba3fc91f894c6e641b97149c8c15d60a53bbd07930926af968eb0c138c1fd931eebe80b36527e356db5b548796 erlang-23.patch
+sha512sums="fa889cbcea0d741149934a78603ccbdf6b6e8c7c6de1938da04b7fbafe4665a675f568c11c74a21f705859563eed129ab437c5fc4da09a6f22d1a872ae8002c2 cloudi-2.0.0.tar.gz
053f860f656617012208a0e1909e43b2f8979d381a90d3fa5a745a9cf5021fe54556a641fef2badaa9955f2394d00e32183389cb9b501169dcbf8cbe4fbb0329 cloudi.initd"
diff --git a/community/cloudi/erlang-23.patch b/community/cloudi/erlang-23.patch
deleted file mode 100644
index 0558f288d14..00000000000
--- a/community/cloudi/erlang-23.patch
+++ /dev/null
@@ -1,252 +0,0 @@
-Upstream: https://github.com/CloudI/CloudI/issues/223
-
-diff --git a/src/external/README.markdown b/src/external/README.markdown
-index bfa39a50..f429bc51 100644
---- a/src/external/README.markdown
-+++ b/src/external/README.markdown
-@@ -204,8 +204,8 @@ Erlang `nodefinder`
- `Strategies for automatic node discovery in Erlang`
-
- - `https://github.com/okeuday/nodefinder`
--- `commit 2edf4824e60821f4d44ea5db92cd689771846387`
--- `Fri Nov 29 04:40:49 UTC 2019`
-+- `commit 58f4cf883b6edbd377ccb3a6da5be177661e36f3`
-+- `Thu Feb 27 21:41:04 UTC 2020`
- - `MIT`
-
- Erlang `parse_trans`
-diff --git a/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder.hrl b/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder.hrl
-index 2a6e9a55..6018b785 100644
---- a/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder.hrl
-+++ b/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder.hrl
-@@ -5,5 +5,16 @@
- -ifdef(ERLANG_OTP_VERSION_19).
- -else.
- -define(ERLANG_OTP_VERSION_20_FEATURES, true).
-+-ifdef(ERLANG_OTP_VERSION_20).
-+-else.
-+-ifdef(OTP_RELEASE).
-+% able to use -if/-elif here
-+-if(?OTP_RELEASE >= 23).
-+-define(ERLANG_OTP_VERSION_23_FEATURES, true).
-+-endif.
-+-else.
-+-error("Erlang/OTP version invalid").
-+-endif.
-+-endif.
- -endif.
-
-diff --git a/src/external/cloudi_x_nodefinder/src_original/nodefinder.hrl b/src/external/cloudi_x_nodefinder/src_original/nodefinder.hrl
-index 2a6e9a55..6018b785 100644
---- a/src/external/cloudi_x_nodefinder/src_original/nodefinder.hrl
-+++ b/src/external/cloudi_x_nodefinder/src_original/nodefinder.hrl
-@@ -5,5 +5,16 @@
- -ifdef(ERLANG_OTP_VERSION_19).
- -else.
- -define(ERLANG_OTP_VERSION_20_FEATURES, true).
-+-ifdef(ERLANG_OTP_VERSION_20).
-+-else.
-+-ifdef(OTP_RELEASE).
-+% able to use -if/-elif here
-+-if(?OTP_RELEASE >= 23).
-+-define(ERLANG_OTP_VERSION_23_FEATURES, true).
-+-endif.
-+-else.
-+-error("Erlang/OTP version invalid").
-+-endif.
-+-endif.
- -endif.
-
-diff --git a/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_ec2_api_aws.erl b/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_ec2_api_aws.erl
-index a5664628..ac6bca86 100644
---- a/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_ec2_api_aws.erl
-+++ b/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_ec2_api_aws.erl
-@@ -38,6 +38,7 @@
- param_list/2
- ]).
-
-+-include("cloudi_x_nodefinder.hrl").
- -include("cloudi_x_nodefinder_ec2_api.hrl").
-
- -define(ERLCLOUD_RETRY_TIMEOUT, 10000).
-@@ -309,6 +310,10 @@ format_timestamp({{Yr, Mo, Da}, {H, M, S}}) ->
- sha256(V) ->
- crypto:hash(sha256, V).
-
-+-ifdef(ERLANG_OTP_VERSION_23_FEATURES).
-+sha256_mac(K, S) ->
-+ crypto:mac(hmac, sha256, K, S).
-+-else.
- sha256_mac(K, S) ->
- crypto:hmac(sha256, K, S).
--
-+-endif.
-diff --git a/src/external/cloudi_x_nodefinder/src_original/nodefinder_ec2_api_aws.erl b/src/external/cloudi_x_nodefinder/src_original/nodefinder_ec2_api_aws.erl
-index a5664628..ac6bca86 100644
---- a/src/external/cloudi_x_nodefinder/src_original/nodefinder_ec2_api_aws.erl
-+++ b/src/external/cloudi_x_nodefinder/src_original/nodefinder_ec2_api_aws.erl
-@@ -38,6 +38,7 @@
- param_list/2
- ]).
-
-+-include("nodefinder.hrl").
- -include("nodefinder_ec2_api.hrl").
-
- -define(ERLCLOUD_RETRY_TIMEOUT, 10000).
-@@ -309,6 +310,10 @@ format_timestamp({{Yr, Mo, Da}, {H, M, S}}) ->
- sha256(V) ->
- crypto:hash(sha256, V).
-
-+-ifdef(ERLANG_OTP_VERSION_23_FEATURES).
-+sha256_mac(K, S) ->
-+ crypto:mac(hmac, sha256, K, S).
-+-else.
- sha256_mac(K, S) ->
- crypto:hmac(sha256, K, S).
--
-+-endif.
-diff --git a/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_multicast.erl b/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_multicast.erl
-index 71b6a54d..df957d8e 100644
---- a/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_multicast.erl
-+++ b/src/external/cloudi_x_nodefinder/src/cloudi_x_nodefinder_multicast.erl
-@@ -223,13 +223,13 @@ process_packet(_Packet, _IP, _State) ->
- ok.
-
- identifier_v4(Message, KeyV4) ->
-- crypto:hmac(sha256, KeyV4, Message).
-+ hmac_sha256(KeyV4, Message).
-
- identifier_v3(Message, KeyV3) ->
-- crypto:hmac(sha256, KeyV3, Message).
-+ hmac_sha256(KeyV3, Message).
-
- identifier_v2(Message, KeyV2) ->
-- crypto:hmac(sha, KeyV2, Message).
-+ hmac_sha(KeyV2, Message).
-
- key_v4() ->
- crypto:hash(sha256, erlang:atom_to_binary(erlang:get_cookie(), utf8)).
-@@ -269,3 +269,16 @@ connect_node(visible, Node) ->
- connect_node(hidden, Node) ->
- net_kernel:hidden_connect_node(Node).
-
-+-ifdef(ERLANG_OTP_VERSION_23_FEATURES).
-+hmac_sha256(Key, Data) ->
-+ crypto:mac(hmac, sha256, Key, Data).
-+
-+hmac_sha(Key, Data) ->
-+ crypto:mac(hmac, sha, Key, Data).
-+-else.
-+hmac_sha256(Key, Data) ->
-+ crypto:hmac(sha256, Key, Data).
-+
-+hmac_sha(Key, Data) ->
-+ crypto:hmac(sha, Key, Data).
-+-endif.
-diff --git a/src/external/cloudi_x_nodefinder/src_original/nodefinder_multicast.erl b/src/external/cloudi_x_nodefinder/src_original/nodefinder_multicast.erl
-index 71b6a54d..df957d8e 100644
---- a/src/external/cloudi_x_nodefinder/src_original/nodefinder_multicast.erl
-+++ b/src/external/cloudi_x_nodefinder/src_original/nodefinder_multicast.erl
-@@ -223,13 +223,13 @@ process_packet(_Packet, _IP, _State) ->
- ok.
-
- identifier_v4(Message, KeyV4) ->
-- crypto:hmac(sha256, KeyV4, Message).
-+ hmac_sha256(KeyV4, Message).
-
- identifier_v3(Message, KeyV3) ->
-- crypto:hmac(sha256, KeyV3, Message).
-+ hmac_sha256(KeyV3, Message).
-
- identifier_v2(Message, KeyV2) ->
-- crypto:hmac(sha, KeyV2, Message).
-+ hmac_sha(KeyV2, Message).
-
- key_v4() ->
- crypto:hash(sha256, erlang:atom_to_binary(erlang:get_cookie(), utf8)).
-@@ -269,3 +269,16 @@ connect_node(visible, Node) ->
- connect_node(hidden, Node) ->
- net_kernel:hidden_connect_node(Node).
-
-+-ifdef(ERLANG_OTP_VERSION_23_FEATURES).
-+hmac_sha256(Key, Data) ->
-+ crypto:mac(hmac, sha256, Key, Data).
-+
-+hmac_sha(Key, Data) ->
-+ crypto:mac(hmac, sha, Key, Data).
-+-else.
-+hmac_sha256(Key, Data) ->
-+ crypto:hmac(sha256, Key, Data).
-+
-+hmac_sha(Key, Data) ->
-+ crypto:hmac(sha, Key, Data).
-+-endif.
-diff --git a/src/lib/cloudi_service_oauth1/src/cloudi_service_oauth1_data.erl b/src/lib/cloudi_service_oauth1/src/cloudi_service_oauth1_data.erl
-index 02450526..e9563e9c 100644
---- a/src/lib/cloudi_service_oauth1/src/cloudi_service_oauth1_data.erl
-+++ b/src/lib/cloudi_service_oauth1/src/cloudi_service_oauth1_data.erl
-@@ -46,6 +46,12 @@
-
- -include_lib("public_key/include/public_key.hrl").
-
-+-ifdef(OTP_RELEASE).
-+-if(?OTP_RELEASE >= 23).
-+-define(ERLANG_OTP_VERSION_23_FEATURES, true).
-+-endif.
-+-endif.
-+
- -spec verify(Signature :: string(),
- HttpMethod :: string(),
- URL :: string(),
-@@ -98,8 +104,13 @@ hmac_sha1_verify(Signature, HttpMethod, URL, Params, Consumer, TokenSecret) ->
- Consumer,
- TokenSecret), Signature).
-
-+-ifdef(ERLANG_OTP_VERSION_23_FEATURES).
-+hmac_sha(Key, Data) ->
-+ crypto:mac(hmac, sha, Key, Data).
-+-else.
- hmac_sha(Key, Data) ->
- crypto:hmac(sha, Key, Data).
-+-endif.
-
- rsa_sha1_verify(Signature, HttpMethod, URL, Params, {_, ConsumerSecret, _}) ->
- BaseString = signature_base_string(HttpMethod, URL, Params),
-@@ -127,6 +138,29 @@ params_encode(Params) ->
- Concatenated = [lists:concat([K, "=", V]) || {K, V} <- Sorted],
- cloudi_string:join("&", Concatenated).
-
-+-ifdef(ERLANG_OTP_VERSION_23_FEATURES).
-+uri_normalize(URI) ->
-+ try uri_string:parse(URI) of
-+ Values ->
-+ Scheme = case maps:get(scheme, Values) of
-+ "http" ->
-+ http;
-+ "https" ->
-+ https;
-+ SchemeStr ->
-+ SchemeStr
-+ end,
-+ UserInfo = maps:get(userinfo, Values),
-+ Host = maps:get(host, Values),
-+ Port = maps:get(port, Values),
-+ Path = maps:get(path, Values),
-+ uri_normalize(Scheme, UserInfo,
-+ cloudi_string:lowercase(Host), Port, [Path])
-+ catch
-+ ErrorType:Error ->
-+ {error, {ErrorType, Error}}
-+ end.
-+-else.
- uri_normalize(URI) ->
- case http_uri:parse(URI) of
- {ok, {Scheme, UserInfo, Host, Port, Path, _Query}} ->
-@@ -135,6 +169,7 @@ uri_normalize(URI) ->
- {error, _} = Error ->
- Error
- end.
-+-endif.
-
- uri_normalize(Scheme, [], Acc) ->
- lists:concat([Scheme, "://" | Acc]);
diff --git a/community/cloudi/fix-new-binutils.patch b/community/cloudi/fix-new-binutils.patch
deleted file mode 100644
index 1c17523d345..00000000000
--- a/community/cloudi/fix-new-binutils.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/src/external/backward-cpp/backward.hpp b/src/external/backward-cpp/backward.hpp
-index 69d5dba..583aa2d 100644
---- a/src/external/backward-cpp/backward.hpp
-+++ b/src/external/backward-cpp/backward.hpp
-@@ -1235,12 +1235,12 @@ private:
- {
- if (result.found) return;
-
-- if ((bfd_get_section_flags(fobj.handle.get(), section)
-+ if ((bfd_section_flags(section)
- & SEC_ALLOC) == 0)
- return; // a debug section is never loaded automatically.
-
-- bfd_vma sec_addr = bfd_get_section_vma(fobj.handle.get(), section);
-- bfd_size_type size = bfd_get_section_size(section);
-+ bfd_vma sec_addr = bfd_section_vma(section);
-+ bfd_size_type size = bfd_section_size(section);
-
- // are we in the boundaries of the section?
- if (addr < sec_addr || addr >= sec_addr + size) {