aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas <3426-spameier@users.gitlab.alpinelinux.org>2023-06-05 18:26:03 +0000
committerpsykose <alice@ayaya.dev>2023-06-05 20:26:03 +0200
commit57479ce7a5080b9f2a00239062df45286ee7827f (patch)
tree16b09068618f5b386c79530e4e4eeefb5ed2fff5
parent0c268dc74691dc4eebef4c57d0c565a4b6cd3184 (diff)
testing/py3-unidns: new aport
-rw-r--r--testing/py3-unidns/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py3-unidns/APKBUILD b/testing/py3-unidns/APKBUILD
new file mode 100644
index 00000000000..6cebb6c0e41
--- /dev/null
+++ b/testing/py3-unidns/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Jonas <3426-spameier@users.gitlab.alpinelinux.org>
+# Maintainer: Jonas <3426-spameier@users.gitlab.alpinelinux.org>
+pkgname=py3-unidns
+_pyname="unidns"
+pkgver=0.0.1
+pkgrel=0
+pkgdesc="Rudimentary async DNS client in Python"
+url="https://github.com/skelsec/unidns"
+arch="noarch"
+license="MIT"
+depends="
+ py3-asysocks
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ py3-setuptools
+ "
+subpackages="$pkgname-pyc $pkgname-examples"
+source="$pkgname-$pkgver.tar.gz::https://github.com/skelsec/unidns/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+options="!check" # no tests provided
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 3 3>&1 >&2
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ dist/*.whl
+}
+
+examples() {
+ pkdesc="$pkgdesc (example client)"
+ depends="$pkgname=$pkgver-r$pkgrel"
+ amove usr/lib/python3.11/site-packages/unidns/examples
+ amove usr/bin
+}
+
+sha512sums="
+5251f740dcb34d78cd8dea2cfd87e1c5ffa5776745ca2d8e080f8a002c3441a96806ec1b244b81cc0e38d5b152a36614da9a3161eeeebf01c28c2c99de046d4c py3-unidns-0.0.1.tar.gz
+"