aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2021-01-12 16:04:37 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-01-13 03:07:43 +0000
commit5794cd8eecd0904ec6cbfbe93d4b8f546a8f041b (patch)
treea0c780ee6b94a110a8ada35a950ef94f5182b5fe
parent1f203ff7468d3bd9bc4fc3bfe16e29debd6fd8a3 (diff)
main/redis: upgrade to 6.0.10
-rw-r--r--main/redis/APKBUILD10
-rw-r--r--main/redis/makefile-dont-duplicate-binary.patch4
-rw-r--r--main/redis/redis.conf.patch14
3 files changed, 15 insertions, 13 deletions
diff --git a/main/redis/APKBUILD b/main/redis/APKBUILD
index f35b6ffe1e9..a377ecab9eb 100644
--- a/main/redis/APKBUILD
+++ b/main/redis/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Eivind Uggedal <eu@eju.no>
# Maintainer: TBK <alpine@jjtc.eu>
pkgname=redis
-pkgver=6.0.9
+pkgver=6.0.10
pkgrel=0
pkgdesc="Advanced key-value store"
url="https://redis.io/"
@@ -14,7 +14,7 @@ makedepends="linux-headers"
checkdepends="tcl procps"
install="$pkgname.pre-install $pkgname.post-install"
subpackages="$pkgname-openrc"
-source="http://download.redis.io/releases/redis-$pkgver.tar.gz
+source="https://download.redis.io/releases/redis-$pkgver.tar.gz
makefile-dont-duplicate-binary.patch
redis.conf.patch
sentinel.conf.patch
@@ -78,9 +78,9 @@ package() {
var/log/redis
}
-sha512sums="ebae2b09637fdbdc71dd22b72ccea24e2c21beb81c6ff5c4bae8b341886a7d847ce868f52dc917079bab8aa250ff61c83efe8acbb8a1cbc5e285c7842b0aefa3 redis-6.0.9.tar.gz
-0a7c165307a01ee89935b160fd38628d9982fc5061fae9a51d80a4932437d9504a53af74be15d0505d0d496d24bbdb6cb45dcf2cf50bddb2d4e34f5cf0fd52c2 makefile-dont-duplicate-binary.patch
-72fcc8d828efe30889c48e9c336e2cdf47c2efd73e7d44eb4bf17972e9f3a1dcea1a01a072eedb0e3c08ad77d3f1ac45249e0f82f4a5f60586a7ede0c840d2f5 redis.conf.patch
+sha512sums="4ef60645316143db3c26c45e90c7dc629e15641313267fd732396212c67db9ebeb9e170d830599b2e143ad5135d1ef249b6fbc1fb4960f4cf857cfdb5c1470c8 redis-6.0.10.tar.gz
+006716439828981ab56bd8837e67d0a99a775e07a80a761903fa762c91571f5e5ffc1a99f0b518a944cbd8635609952ded838f342d5563345199f8e6e6579efd makefile-dont-duplicate-binary.patch
+05a35246ee5136f10f1873eb91a267cf31d206d298ff8ac105efc501bbab7f44b50d4e4d92874701c81e105bd72a0ac73f5e810610de8e3769544e7c36a23748 redis.conf.patch
a5dc411c2bd7edf61400e29accb375275dd888fda72a8f7e3889be475010c695a22f536be818ef9441e47285c00b451966db924362a7f56806586078c9e3ff8c sentinel.conf.patch
f6dcdad1edd6b5fb6aa28ba774bfc8aba035f316695da261fb2ad291b76f00f177479f9d74434d06c26bd15f131edc9a2f55c9880758cf0987800d2031069738 redis.initd
6752e99df632b14d62a3266929e80c3d667be5c270e4f34e0dcf2b7f9b1754fe0ce9d4569fa413dbbe207e406ff2848a64e0c47629997536ae1d14ca84ebd56b redis.confd
diff --git a/main/redis/makefile-dont-duplicate-binary.patch b/main/redis/makefile-dont-duplicate-binary.patch
index 7a166d4ef10..a3382ce7d4c 100644
--- a/main/redis/makefile-dont-duplicate-binary.patch
+++ b/main/redis/makefile-dont-duplicate-binary.patch
@@ -2,9 +2,11 @@ redis-check-rdb and redis-check-aof binaries are identical to redis-server.
See https://github.com/antirez/redis/pull/3494
+As of v6.2 this patch should no longer be needed - https://github.com/redis/redis/pull/5745
+
--- a/src/Makefile
+++ b/src/Makefile
-@@ -353,9 +353,9 @@
+@@ -394,9 +394,9 @@
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
diff --git a/main/redis/redis.conf.patch b/main/redis/redis.conf.patch
index ae366a59ebb..14f3111423f 100644
--- a/main/redis/redis.conf.patch
+++ b/main/redis/redis.conf.patch
@@ -7,7 +7,7 @@ convenient to have it enabled by default.
--- a/redis.conf
+++ b/redis.conf
-@@ -106,8 +106,8 @@
+@@ -105,8 +105,8 @@
# incoming connections. There is no default, so Redis will not listen
# on a unix socket when not specified.
#
@@ -18,7 +18,7 @@ convenient to have it enabled by default.
# Close the connection after a client is idle for N seconds (0 to disable)
timeout 0
-@@ -200,10 +200,6 @@
+@@ -219,10 +219,6 @@
################################# GENERAL #####################################
@@ -29,8 +29,8 @@ convenient to have it enabled by default.
# If you run Redis from upstart or systemd, Redis can interact with your
# supervision tree. Options:
# supervised no - no supervision interaction
-@@ -215,17 +211,6 @@
- # They do not enable continuous liveness pings back to your supervisor.
+@@ -235,17 +231,6 @@
+ # They do not enable continuous pings back to your supervisor.
supervised no
-# If a pid file is specified, Redis writes it where specified at startup
@@ -47,7 +47,7 @@ convenient to have it enabled by default.
# Specify the server verbosity level.
# This can be one of:
# debug (a lot of information, useful for development/testing)
-@@ -237,7 +222,7 @@
+@@ -257,7 +242,7 @@
# Specify the log file name. Also the empty string can be used to force
# Redis to log on the standard output. Note that if you use standard
# output for logging but daemonize, logs will be sent to /dev/null
@@ -56,7 +56,7 @@ convenient to have it enabled by default.
# To enable logging to the system logger, just set 'syslog-enabled' to yes,
# and optionally update the other syslog parameters to suit your needs.
-@@ -260,7 +245,7 @@
+@@ -280,7 +265,7 @@
#
# However it is possible to force the pre-4.0 behavior and always show a
# ASCII art logo in startup logs by setting the following option to yes.
@@ -65,7 +65,7 @@ convenient to have it enabled by default.
################################ SNAPSHOTTING ################################
#
-@@ -342,7 +327,7 @@
+@@ -362,7 +347,7 @@
# The Append Only File will also be created inside this directory.
#
# Note that you must specify a directory here, not a file name.