aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze <noel.kuntze@thermi.consulting>2020-07-29 07:59:47 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-05 19:10:34 -0300
commit5795d58135c249a125fb972e788890bb668a75c8 (patch)
treeb27a7d43a5778b48f0bef2a6cb5567a73138ecd7
parentc5d2f49e120ab42b4b0a96cdcc06aa3eb2a3b8bc (diff)
testing/py3-daemon: new aport
Library to implement a well-behaved Unix daemon process https://pagure.io/python-daemon Co-authored-by: Leo <thinkabit.ukim@gmail.com>
-rw-r--r--testing/py3-daemon/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-daemon/APKBUILD b/testing/py3-daemon/APKBUILD
new file mode 100644
index 00000000000..f6fa635e03e
--- /dev/null
+++ b/testing/py3-daemon/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Noel Kuntze <noel.kuntze@thermi.consulting>
+# Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
+pkgname=py3-daemon
+pkgver=2.2.4
+pkgrel=0
+pkgdesc="Library to implement a well-behaved Unix daemon process"
+url="https://pagure.io/python-daemon"
+options="!check" # Has lots of dependencies
+arch="noarch"
+license="Apache-2.0 AND GPL-3.0-or-later"
+depends="py3-setuptools py3-lockfile"
+makedepends="py3-twine py3-docutils"
+source="https://pypi.io/packages/source/p/python-daemon/python-daemon-$pkgver.tar.gz"
+builddir="$srcdir/python-daemon-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --root="$pkgdir"
+}
+
+sha512sums="9a7a4e23e126f05e4c1c503f15401cddd758c5f9195c370997060ca1bbfe71cc51d82d3ae16bcf0023c28fa50b0b8d6cd406e515b27725ffa9fec10fde3ed64a python-daemon-2.2.4.tar.gz"