aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNewbyte <newbie13xd@gmail.com>2020-10-03 17:33:57 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-10-15 23:56:52 +0000
commit58c2b3bb76c3c171c4ca807aa065bbc228418a9a (patch)
treef53aeef65e8799849e80e775efa9c36125539515
parent584b2a44b991b72ca8af9fd11a9ce2ff4ce57128 (diff)
main/mesa: upgrade to 20.2.1
-rw-r--r--main/mesa/APKBUILD10
-rw-r--r--main/mesa/add-use-elf-tls.patch14
-rw-r--r--main/mesa/musl-fix-includes.patch22
3 files changed, 20 insertions, 26 deletions
diff --git a/main/mesa/APKBUILD b/main/mesa/APKBUILD
index fa2c0dd888e..6659060f631 100644
--- a/main/mesa/APKBUILD
+++ b/main/mesa/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
-pkgver=20.1.9
+pkgver=20.2.1
pkgrel=0
pkgdesc="Mesa DRI OpenGL library"
url="https://www.mesa3d.org"
@@ -121,6 +121,8 @@ build() {
export CFLAGS="$CFLAGS -D_XOPEN_SOURCE=700"
export MESA_GIT_SHA1_OVERRIDE=53b2b224dc2de982c37915a0ad218e33365ff75e
+ python3 bin/git_sha1_gen.py --output src/freedreno/common/git_sha1.h
+
abuild-meson \
-Ddri-drivers-path=$_dri_driverdir \
-Dgallium-drivers=$_gallium_drivers \
@@ -322,9 +324,9 @@ _vulkan_layer() {
mv "$pkgdir"/usr/bin/mesa-overlay-control.py "$subpkgdir"/usr/bin
}
-sha512sums="0fb8ceff3c91ad2076efb0b2ac7e95d2d72ff1df955eb8fedf712ceaa7f49184eae9958072edd872f5c38adbaeb867988f67627b33da8b208706f69325d7e260 mesa-20.1.9.tar.xz
+sha512sums="5d609359754db3e3679bffd5306c1f1d1cf46a2ea98428a9451fe0d99bbf73da863c5d94e6561712cd2012ad13615666cf3d712e54f379b34c091fead39d4795 mesa-20.2.1.tar.xz
cdf22d2da3328e116c379264886bd01fd3ad5cc45fe03dc6fd97bdc4794502598ee195c0b9d975fa264d6ac31c6fa108c0535c91800ecf4fcabfd308e53074cc adjust-cache-deflate-buffer.patch
-cf849044d6cc7d2af4ff015208fb09d70bf9660538699797da21bda2ecb7c1892d312af83d05116afd826708d9caafb1d05a13f09139c558aea6fee931e3eee7 musl-fix-includes.patch
-cd3961319079882e692176f654feb21ddfeccafcc7f4ce4f8d21160f36deda768eb3ee7f49dae2e18f0587d321473adc7f127a2d75ae143ec29168bcc0fe12c0 add-use-elf-tls.patch
+77b40d3b70a78e1f261f0a0358f3b5f15d5f0a6d51ba317e38053f426a14487a459743df2e4734e9c086f1f083572e78279eb8a5dde191ef0c2914594513194b musl-fix-includes.patch
+ed65ff134022f839f1395f51683d1bb2e61586163516bf104450c96707b7071d80475c2f2d905b77892658257fdfea040a84b6d9b8b23d669924ebd5d7eca055 add-use-elf-tls.patch
ede642ae9be64c3fc5fee46e8bf1b2f982191febcfadb235b0261868213c7cca11d38bb53b972f3184a887430f37b9f470a9b12fd03cf54b98315ec75c4d8ed4 disable-rgb10-by-default.patch
fdbc13888f09d157feae6ce3b8a63cc606d7ed19e364cdb89ccce25a367255b498bbe82862a487c29d8f98d5e31980ef1f0879b06823cedb54801fd54cd461ad 0001-radeonsi-On-Aarch64-force-persistent-buffers-to-GTT.patch"
diff --git a/main/mesa/add-use-elf-tls.patch b/main/mesa/add-use-elf-tls.patch
index a5cb6201727..f54b0b0c28a 100644
--- a/main/mesa/add-use-elf-tls.patch
+++ b/main/mesa/add-use-elf-tls.patch
@@ -1,22 +1,22 @@
diff --git a/meson.build b/meson.build
-index d228de0..63818c5 100644
+index 76f72a9df7c..2802467f70e 100644
--- a/meson.build
+++ b/meson.build
-@@ -392,7 +392,8 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
- endif
+@@ -437,7 +437,8 @@ endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
--if not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+ use_elf_tls = false
+-if not ['windows', 'freebsd', 'openbsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+with_use_elf_tls = get_option('use-elf-tls')
+if with_use_elf_tls and not ['windows', 'freebsd'].contains(host_machine.system()) and (not with_platform_android or get_option('platform-sdk-version') >= 29)
pre_args += '-DUSE_ELF_TLS'
+ use_elf_tls = true
endif
-
diff --git a/meson_options.txt b/meson_options.txt
-index ab43150..435a6e9 100644
+index bf031eeb11f..46bd7c4d898 100644
--- a/meson_options.txt
+++ b/meson_options.txt
-@@ -387,3 +387,9 @@ option(
+@@ -406,3 +406,9 @@ option(
value : 'auto',
description : 'Use ZSTD instead of ZLIB in some cases.'
)
diff --git a/main/mesa/musl-fix-includes.patch b/main/mesa/musl-fix-includes.patch
index 9ce9df4e4e9..8553d44894f 100644
--- a/main/mesa/musl-fix-includes.patch
+++ b/main/mesa/musl-fix-includes.patch
@@ -1,21 +1,13 @@
+diff --git a/src/util/rand_xor.c b/src/util/rand_xor.c
+index 81b64f1ea71..14e6c9d27c3 100644
--- a/src/util/rand_xor.c
+++ b/src/util/rand_xor.c
-@@ -24,6 +24,8 @@
-
- #if defined(__linux__)
- #include <sys/file.h>
+@@ -27,6 +27,8 @@
+ #if !DETECT_OS_WINDOWS
+ #if defined(HAVE_GETRANDOM)
+ #include <sys/random.h>
+#include <sys/types.h>
+#include <sys/stat.h>
+ #endif
#include <unistd.h>
#include <fcntl.h>
- #else
---- ./src/gallium/winsys/svga/drm/vmw_screen.h.orig
-+++ ./src/gallium/winsys/svga/drm/vmw_screen.h
-@@ -34,7 +34,7 @@
- #ifndef VMW_SCREEN_H_
- #define VMW_SCREEN_H_
-
--
-+#include <sys/stat.h>
- #include "pipe/p_compiler.h"
- #include "pipe/p_state.h"