aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoni Aloy Torrens <aaloytorrens@gmail.com>2021-02-12 02:22:18 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-03-21 07:10:38 +0000
commit5a05dac9b9dc2ca5f99c09191243aa6aa3a1b74b (patch)
tree48fa8b3181218341244ee9602fc2fc4215eef63e
parent3fc778c0d4e722d591f082f84754ca9ba2be321a (diff)
testing/lxqt-qtplugin: new aport
-rw-r--r--testing/lxqt-qtplugin/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/lxqt-qtplugin/APKBUILD b/testing/lxqt-qtplugin/APKBUILD
new file mode 100644
index 00000000000..d294e354d1e
--- /dev/null
+++ b/testing/lxqt-qtplugin/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=lxqt-qtplugin
+pkgver=0.16.0
+pkgrel=0
+pkgdesc="Qt-LXQt plugin integration"
+url="https://github.com/lxqt/lxqt-qtplugin"
+arch="all !s390x" # s390x blocked by libfm-qt
+license="LGPL-2.0-or-later"
+makedepends="
+ cmake lxqt-build-tools liblxqt-dev libdbusmenu-qt-dev
+ libfm-qt-dev qt5-qttools-dev
+ "
+options="!check" # No testsuite
+source="https://github.com/lxqt/lxqt-qtplugin/releases/download/$pkgver/lxqt-qtplugin-$pkgver.tar.xz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+sha512sums="8dc6174a5b2a43332b40509b466095912d31407e70d5d3487243de3a25fd07e925fae8f46359f6b69f2e4d7e920a7ba0ae5982a8d7ad9129ffacb4d62e108203 lxqt-qtplugin-0.16.0.tar.xz"