aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2021-03-24 12:41:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2021-04-05 18:18:59 +0000
commit5a251b7fca201652ae6657de055ddacbe808898f (patch)
tree67080d051a23fec2586423c058b699054c9a2eb9
parente45145317c93ad77dacee23613cfdfd5d673609d (diff)
testing/libsigrokdecode: fix build with python 3.9
-rw-r--r--testing/libsigrokdecode/APKBUILD6
-rw-r--r--testing/libsigrokdecode/python-3.9.patch25
2 files changed, 29 insertions, 2 deletions
diff --git a/testing/libsigrokdecode/APKBUILD b/testing/libsigrokdecode/APKBUILD
index 3ddd7f7c743..924888f034d 100644
--- a/testing/libsigrokdecode/APKBUILD
+++ b/testing/libsigrokdecode/APKBUILD
@@ -2,7 +2,7 @@
pkgname="libsigrokdecode"
pkgver=0.5.3
-pkgrel=0
+pkgrel=1
pkgdesc="A C library to decode protocol data captured by logic analyzers"
url="https://sigrok.org/wiki/Libsigrokdecode"
makedepends="glib-dev libserialport-dev libzip-dev libusb-dev libftdi1-dev
@@ -12,6 +12,7 @@ arch="all"
license="GPL-3.0-only"
source="http://sigrok.org/download/source/libsigrokdecode/libsigrokdecode-$pkgver.tar.gz
version.patch
+ python-3.9.patch
"
subpackages="$pkgname-dev"
@@ -34,4 +35,5 @@ package() {
}
sha512sums="23393504b68135ed4ae8e8a654df024620af02e84fa3955956c61899388812229108155b4ae8d946e61f33dc8a8807db090d608350548a7a717d966442b07b9e libsigrokdecode-0.5.3.tar.gz
-6d8fa69a891b4333fe77213cf75df218090e58b51d6c92197351d95a977634f2228a63c9c0c75fcb1d816c59ee9eaf410d5e79827ac7c79b0784262ea0f9c3fd version.patch"
+6d8fa69a891b4333fe77213cf75df218090e58b51d6c92197351d95a977634f2228a63c9c0c75fcb1d816c59ee9eaf410d5e79827ac7c79b0784262ea0f9c3fd version.patch
+1b87e320d167b2c57c93e346494f5009baf1071e9df19a7c6060603ca8327b1b9d2c84d69e695dd54a9f08e13bae285fc4c10ee7060a0f75a1d844c96c4e7657 python-3.9.patch"
diff --git a/testing/libsigrokdecode/python-3.9.patch b/testing/libsigrokdecode/python-3.9.patch
new file mode 100644
index 00000000000..da95e90a8bd
--- /dev/null
+++ b/testing/libsigrokdecode/python-3.9.patch
@@ -0,0 +1,25 @@
+From 9b0ad5177bd692f7556a4756bdbd2da81d9c34ce Mon Sep 17 00:00:00 2001
+From: =?utf8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
+Date: Tue, 4 Aug 2020 09:19:44 +0200
+Subject: [PATCH] configure.ac: Add support for Python 3.9.
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f9958b3..2917cb3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -100,7 +100,7 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
+ # first, since usually only that variant will add "-lpython3.8".
+ # https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
+ SR_PKG_CHECK([python3], [SRD_PKGLIBS],
+- [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
++ [python-3.9-embed], [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
+ AS_IF([test "x$sr_have_python3" = xno],
+ [AC_MSG_ERROR([Cannot find Python 3 development headers.])])
+
+--
+2.24.0.rc2
+