aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoromni <omni@gitlab.alpinelinux.org>2021-02-16 09:00:27 +0000
committerLeo <thinkabit.ukim@gmail.com>2021-02-17 16:52:05 +0000
commit5a87878a009959a750a8418be5a47653d15bbe76 (patch)
tree90642bf0c01490ee8987edb43bbcf3bbf572d2d5
parentc9938b43dcb34fbd414f2ca745b8a643ab60d80d (diff)
testing/dog: new aport
The man page could be generated with `just man` but would require `pandoc` that is in testing. A smaller alternative could be to package `md2roff` or something.
-rw-r--r--testing/dog/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/dog/APKBUILD b/testing/dog/APKBUILD
new file mode 100644
index 00000000000..466eb2f0fc0
--- /dev/null
+++ b/testing/dog/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: omni <omni@gitlab.alpinelinux.org>
+# Maintainer: omni <omni@gitlab.alpinelinux.org>
+pkgname=dog
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="dog is a command-line DNS client"
+url="https://github.com/ogham/dog"
+arch="x86_64 armv7 armhf aarch64 ppc64le x86"
+license="EUPL-1.2"
+makedepends="cargo openssl-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ogham/dog/archive/v$pkgver.tar.gz"
+
+build() {
+ cargo build --locked --release
+}
+
+check() {
+ cargo test --locked --release
+}
+
+package() {
+ install -Dm0755 target/release/$pkgname -t "$pkgdir"/usr/bin
+ install -Dm0644 man/dog.1.md -t "$pkgdir"/usr/share/doc/"$pkgname"
+ install -Dm0644 LICENCE -t "$pkgdir"/usr/share/licenses/"$pkgname"
+}
+
+sha512sums="03af5414b995710d22ea19bdbf382def4e53ae2870f396b4103546743c9cafcc445ee0819b6c8b7f435793fead5ebd03f091be89293a32847868a5544b4bc0e5 dog-0.1.0.tar.gz"