aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-11-27 09:32:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-11-27 09:36:05 +0000
commit5cae60103c04f139e3fd5620746d2ca52b1ca233 (patch)
tree8820afd160567e5bfca023d1b5de3b4d2e596593
parentcf4d805007d7b295de89bb55740b2ca6b6150e78 (diff)
community/geoclue: disable modemmanager on s390x
modemmanager depends on polkit -> mozjs -> rust and rust does not yet work on s390x.
-rw-r--r--community/geoclue/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/community/geoclue/APKBUILD b/community/geoclue/APKBUILD
index 4773b906987..c640e93a5da 100644
--- a/community/geoclue/APKBUILD
+++ b/community/geoclue/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=geoclue
pkgver=2.5.6
-pkgrel=1
+pkgrel=2
pkgdesc="dbus geolocation service"
url="https://www.freedesktop.org/wiki/Software/GeoClue/"
arch="all"
@@ -11,7 +11,6 @@ makedepends="
meson
libsoup-dev
json-glib-dev
- modemmanager-dev
avahi-dev
intltool
gobject-introspection-dev
@@ -21,12 +20,21 @@ subpackages="$pkgname-dev $pkgname-doc"
install="$pkgname.pre-install"
source="https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/$pkgver/geoclue-$pkgver.tar.bz2"
+case "$CARCH" in
+ s390x) _arch_opts="-D3g-source=off -Dcdma-source=off -Dmodem-gps-source=off"
+ ;;
+ *) _arch_opts=""
+ makedepends="$makedepends modemmanager-dev"
+ ;;
+esac
+
build() {
abuild-meson \
-Ddbus-srv-user=geoclue \
-Ddbus-sys-dir=/usr/share/dbus-1/system.d \
-Dgtk-doc=false \
-Dintrospection=true \
+ $_arch_opts \
build
meson compile ${JOBS:+-j ${JOBS}} -C build
}