aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-08-22 14:08:19 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-22 14:08:19 +0200
commit5d56bc12e2864ffcdcd853e57c15473d38eb6bf2 (patch)
tree86fe621d14c2438b27a40329ca25fa6ad6daaa37
parent4e69ccd0206bb098300df19927f57892fb338ba8 (diff)
community/py3-authlib: new aport
https://github.com/lepture/authlib The ultimate Python library in building OAuth and OpenID Connect servers
-rw-r--r--community/py3-authlib/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-authlib/APKBUILD b/community/py3-authlib/APKBUILD
new file mode 100644
index 00000000000..c093150c5cb
--- /dev/null
+++ b/community/py3-authlib/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-authlib
+pkgver=0.14.3
+pkgrel=0
+pkgdesc="The ultimate Python library in building OAuth and OpenID Connect servers"
+url="https://github.com/lepture/authlib"
+arch="all"
+license="BSD-3-Clause"
+depends="python3 py3-cryptography"
+makedepends="py3-setuptools"
+#checkdepends="py3-django py3-flask-sqlalchemy"
+options="!check" # missing deps: py3-httpx, py3-starlette,py3-pytest-django
+source="https://pypi.io/packages/source/A/Authlib/Authlib-$pkgver.tar.gz"
+builddir="$srcdir/Authlib-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="19f42c6b7c718ea2021ce1df8716fa87a40d0ac7d7efb5b4b905949150400a16b902302f84697e181adab2880c2028332dac060881fbbb716eca354c4159c7c4 Authlib-0.14.3.tar.gz"