aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2020-07-11 16:06:13 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-07-11 13:45:43 +0000
commit5e0bbaef4bfdc24b3fd9ff8fd57ba2db58684b9e (patch)
tree96558a89719368cee66f61226731c203d955b237
parentc7f33d6da2aba37dcfe6fefd473afed71bc3667b (diff)
testing/leiningen: upgrade to 2.9.4
* Add bash runtime dependency. * Add completions for bash and zsh. * Import upstream patch to fix quoting.
-rw-r--r--[-rwxr-xr-x]testing/leiningen/APKBUILD22
-rw-r--r--testing/leiningen/fix-missing-quote.patch23
2 files changed, 39 insertions, 6 deletions
diff --git a/testing/leiningen/APKBUILD b/testing/leiningen/APKBUILD
index 55d101ea48f..1a96f44230e 100755..100644
--- a/testing/leiningen/APKBUILD
+++ b/testing/leiningen/APKBUILD
@@ -1,17 +1,21 @@
# Contributor: Will Sinatra <wpsinatra@gmail.com>
# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=leiningen
-pkgver=2.9.3
+pkgver=2.9.4
pkgrel=0
pkgdesc="Automate Clojure Projects"
options="!check" #No Checks
url="https://leiningen.org/"
arch="noarch !mips !mips64" # java
license="EPL-1.0"
-depends="openjdk8"
-subpackages="$pkgname-doc"
+depends="bash openjdk8"
+subpackages="$pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-zsh-completion
+ "
source="leiningen-$pkgver.tar.gz::https://github.com/technomancy/leiningen/archive/$pkgver.tar.gz
- https://github.com/technomancy/leiningen/releases/download/$pkgver/leiningen-$pkgver-standalone.zip"
+ https://github.com/technomancy/leiningen/releases/download/$pkgver/leiningen-$pkgver-standalone.zip
+ fix-missing-quote.patch"
package() {
install -Dm755 "$builddir/bin/lein-pkg" \
@@ -22,7 +26,13 @@ package() {
install -Dm 644 "$srcdir/leiningen-$pkgver-standalone.zip" \
"$pkgdir/usr/share/java/leiningen-$pkgver-standalone.jar"
+
+ install -Dm644 bash_completion.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/lein
+ install -Dm644 zsh_completion.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_lein
}
-sha512sums="d37ffe9f2ec8477b481e913a032f7bb307292a96ead213acee8c45585eb3988be6fa58cb45c745c9eeb30f78ea8b27afc1ce2ae2df4998c205e76dc9dd9068a6 leiningen-2.9.3.tar.gz
-2f716e37e68ae994f998027cd2d8c8705e4fdafb513edc91a8acdd833d3f388882f5f33446b56e0c5ce4c196d9337ce46e174f73231ec8b648fe630e366bf9bf leiningen-2.9.3-standalone.zip"
+sha512sums="980bb74b29774b8595d8a1fc2aee61dd674a12b853d3cad751bf54700cab0109c2c87ffceb303c0b656fe89bc569021fcf11740175aa29d839ccbc9014a32fd3 leiningen-2.9.4.tar.gz
+d6cb1a26a24b183a1a805ed6c79b3e42fd689396574b802448dbca26869f8530ff7ef414212c198450a540e699ac072e73330395c5035d62db8e2e0e777d45c3 leiningen-2.9.4-standalone.zip
+3632075bf17370be83ebad8a096da7adea7d242ab6b547898be339dcca7999bc5525b9f56fc7dbe541333e556365ab8ebb1da1575ff8a786e9f6bec9c8947d38 fix-missing-quote.patch"
diff --git a/testing/leiningen/fix-missing-quote.patch b/testing/leiningen/fix-missing-quote.patch
new file mode 100644
index 00000000000..e8ad23baaba
--- /dev/null
+++ b/testing/leiningen/fix-missing-quote.patch
@@ -0,0 +1,23 @@
+From 7677dabea40a2d17a42a718ca8c7e450b09e153c Mon Sep 17 00:00:00 2001
+From: Phil Hagelberg <phil@hagelb.org>
+Date: Wed, 8 Jul 2020 14:31:03 -0700
+Subject: [PATCH] Fix missing quote in bin/lein-pkg.
+
+Fixes #2691
+---
+ bin/lein-pkg | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/bin/lein-pkg b/bin/lein-pkg
+index 4642196a3..b45cf594a 100644
+--- a/bin/lein-pkg
++++ b/bin/lein-pkg
+@@ -86,7 +86,7 @@ if [ -r .lein-fast-trampoline ]; then
+ fi
+
+ if [ "$LEIN_FAST_TRAMPOLINE" != "" ] && [ -r project.clj ]; then
+- INPUTS="$* $(cat project.clj) $LEIN_VERSION $(test -f "$LEIN_HOME/profiles.clj" && cat "$LEIN_HOME/profiles.clj") $(test -f profiles.clj && cat profiles.clj)
++ INPUTS="$* $(cat project.clj) $LEIN_VERSION $(test -f "$LEIN_HOME/profiles.clj" && cat "$LEIN_HOME/profiles.clj") $(test -f profiles.clj && cat profiles.clj)"
+
+ if command -v shasum >/dev/null 2>&1; then
+ SUM="shasum"