aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-08-13 13:35:04 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-16 23:18:46 +0000
commit5e221944d29b77ce6e75756fcb2e2751e446dd64 (patch)
treef71b861a584a08c21897d46352b35ef9d19ba101
parente9ec839c806359814c836d727a7069d17537eac1 (diff)
testing/py3-sphobjinv: new aport
https://github.com/bskinn/sphobjinv Sphinx objects.inv Inspection/Manipulation Tool testing/
-rw-r--r--testing/py3-sphobjinv/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-sphobjinv/APKBUILD b/testing/py3-sphobjinv/APKBUILD
new file mode 100644
index 00000000000..f648eb4b7e0
--- /dev/null
+++ b/testing/py3-sphobjinv/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=py3-sphobjinv
+_pyname=sphobjinv
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="Sphinx objects.inv Inspection/Manipulation Tool"
+url="https://github.com/bskinn/sphobjinv"
+arch="noarch"
+license="MIT"
+options="!check" # no tests
+depends="python3 py3-attrs py3-certifi py3-jsonschema py3-fuzzywuzzy"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="bc471fdd41d54d3483781a0c7214bd65711872a62bb7c03473bd731f70c853c1a4030a3a920db27bc0669ded3177d52847c43abc0da5edbc9683ffef0d0b1e99 sphobjinv-2.0.1.tar.gz"