aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 03:44:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 07:58:06 -0300
commit5e2c8238e96487c581bd953f09ad55de76f0c818 (patch)
tree7b314c01ae36aa9a4100c99083affeb95f4abc09
parent7b7ca771d78c9022ac82c8e36de326548fbacdb3 (diff)
community/lua-argparse: enable luajit on s390x
-rw-r--r--community/lua-argparse/APKBUILD13
1 files changed, 2 insertions, 11 deletions
diff --git a/community/lua-argparse/APKBUILD b/community/lua-argparse/APKBUILD
index 0b95426eb6d..d62a280253e 100644
--- a/community/lua-argparse/APKBUILD
+++ b/community/lua-argparse/APKBUILD
@@ -8,18 +8,10 @@ pkgdesc="Feature-rich command line parser for Lua"
url="https://github.com/mpeterv/argparse"
arch="noarch"
license="MIT"
-depends=""
-checkdepends="lua-busted"
-subpackages=""
+checkdepends="lua-busted luajit"
source="$pkgname-$pkgver.tar.gz::https://github.com/mpeterv/$_pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-# luajit is not available for selected arches
-case "$CARCH" in
- s390x) _luajit="";;
- *) checkdepends="$checkdepends luajit" _luajit="jit";;
-esac
-
_luaversions="5.1 5.2 5.3"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
@@ -27,10 +19,9 @@ for _v in $_luaversions; do
done
check() {
- cd "$builddir"
mkdir .bin
- local lver; for lver in $_luaversions $_luajit; do
+ local lver; for lver in $_luaversions jit; do
msg "Testing on lua$lver"
ln -sf /usr/bin/lua$lver .bin/lua