aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClayton Craft <clayton@craftyguy.net>2020-02-07 23:33:49 -0800
committerRasmus Thomsen <oss@cogitri.dev>2020-03-07 10:38:28 +0100
commit5ebfb4f3d02838c7f21b4a161d27e420522497e3 (patch)
treeb27bd9686eb9d9ead007c0abad3c0c9d0df45519
parentad48f1d20bc91e1d48c65e7cf06497f11a9d3aa6 (diff)
testing/unshield: new aport
This is a dependency for openmw. This APKBUILD is loosely based of of the PKGBUILD in Arch Linux for this package
-rw-r--r--testing/unshield/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/unshield/APKBUILD b/testing/unshield/APKBUILD
new file mode 100644
index 00000000000..53fc21130ae
--- /dev/null
+++ b/testing/unshield/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+pkgname=unshield
+pkgver=1.4.3
+pkgrel=0
+pkgdesc="Extracts CAB files from InstallShield installers"
+# Note: only tested on the following archs, may work on others too but not
+# adding them until this has been confirmed
+arch="x86_64 aarch64"
+url="https://github.com/twogood/unshield"
+license="MIT"
+makedepends="cmake zlib-dev"
+checkdepends="bash"
+source="$pkgname-$pkgver.tar.gz::https://github.com/twogood/unshield/archive/$pkgver.tar.gz"
+subpackages="
+ $pkgname-doc
+ $pkgname-dev
+ "
+options="!check"
+# Package includes unit tests but they fail to execute:
+# https://github.com/twogood/unshield/issues/99
+
+build() {
+ cmake -B build . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=None
+ make -C build
+}
+
+check() {
+ UNSHIELD=$builddir/src/unshield bash run-tests.sh
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir" install
+}
+sha512sums="2f058e0a28d0497e2afe231ded1b1bb16745401398eb1035e628d263351b10a1343c9664f3937b8912755db9dc5236a1b43e9bcba596affb7aa8b036f49382aa unshield-1.4.3.tar.gz"