aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-06-23 18:05:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-06-23 22:10:31 +0000
commit5f18e0a11305ba487efe5b3ce8432aa6cb7f3e88 (patch)
tree640aca935a82b7a30fe40083f60783e40a7d14f8
parentf6474457dd53b83dc41077b5eff1b4ebaecce960 (diff)
main/popt: upgrade to 1.18
-rw-r--r--main/popt/APKBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/main/popt/APKBUILD b/main/popt/APKBUILD
index 7d6d72d89e5..6f11ae264cc 100644
--- a/main/popt/APKBUILD
+++ b/main/popt/APKBUILD
@@ -1,24 +1,16 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=popt
-pkgver=1.16
-pkgrel=7
-pkgdesc="A commandline option parser"
-url="http://rpm5.org"
+pkgver=1.18
+pkgrel=0
+pkgdesc="commandline option parser"
+url="https://github.com/rpm-software-management/popt"
arch="all"
-license="custom"
-depends=
-makedepends=""
-source="$pkgname-$pkgver.tar.gz::https://deb.debian.org/debian/pool/main/p/$pkgname/${pkgname}_${pkgver}.orig.tar.gz"
+license="MIT"
subpackages="$pkgname-doc $pkgname-dev"
-
-prepare() {
- cd "$builddir"
- default_prepare
- update_config_sub
-}
+source="http://ftp.rpm.org/popt/releases/popt-${pkgver%.*}.x/popt-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,14 +21,15 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+
+ mkdir -p "$pkgdir"/usr/lib
+ mv "$pkgdir"/lib/pkgconfig "$pkgdir"/usr/lib
}
-sha512sums="bae2dd4e5d682ef023fdc77ae60c4aad01a3a576d45af9d78d22490c11e410e60edda37ede171920746d4ae0d5de3c060d15cecfd41ba75b727a811be828d694 popt-1.16.tar.gz"
+sha512sums="86422e8762adda3d02d46c20ac74ffe389d4f991d552b6fea729f007345b6426cbeb71160284e2deaa2ce44ce754a9e6cf6ccbd64bff9bc2253df40cdc2f79a5 popt-1.18.tar.gz"