aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-11-19 15:29:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-11-19 15:29:36 +0000
commit619f36b23eb48b5950ee049b0ab7c43ade2c8790 (patch)
tree41c67d2bc61cabbd93687e0a00b93ddf078f9c77
parentb938572c8b3b66ad8a0a3cb09ea747d70a287a64 (diff)
community/runc: strip elf symbols and debugging info
saves a couple of MB
-rw-r--r--community/runc/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/runc/APKBUILD b/community/runc/APKBUILD
index 7e969bc96c6..c5c17ab1bd2 100644
--- a/community/runc/APKBUILD
+++ b/community/runc/APKBUILD
@@ -7,7 +7,7 @@ url="https://www.opencontainers.org"
_commit=ff819c7e9184c13b7c2607fe6c30ae19403a7aff
pkgver=1.0.0_rc92
-pkgrel=0
+pkgrel=1
_ver=v${pkgver/_rc/-rc}
# if we're building against an explicit commit beyond pkgver, use this instead:
@@ -35,7 +35,7 @@ build() {
mkdir -p "$(dirname "$builddir")"
ln -s "$PWD/$pkgname-${_ver#v}" "$builddir"
cd "$builddir"
- make COMMIT="$_commit"
+ make COMMIT="$_commit" EXTRA_LDFLAGS="-w -s"
make man
}