aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2021-02-28 02:12:47 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2021-03-05 16:17:51 +0000
commit66215fb38e974f058eb54003996363b0c39f5969 (patch)
treec1e1373ee3d0eda17c8351c3f78a2271f045e4d0
parent8de1e3fd882d0c9ab40f8ac0fc307a9ee78c81bf (diff)
community/gitlab-runner: upgrade to 13.9.0
-rw-r--r--community/gitlab-runner/APKBUILD12
-rw-r--r--community/gitlab-runner/change-deps.patch61
-rw-r--r--community/gitlab-runner/fix-docker-linux-stat.patch13
3 files changed, 4 insertions, 82 deletions
diff --git a/community/gitlab-runner/APKBUILD b/community/gitlab-runner/APKBUILD
index 1eab59d7b78..de5a58ea3fd 100644
--- a/community/gitlab-runner/APKBUILD
+++ b/community/gitlab-runner/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Rasmus Thomsen <oss@cogitir.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gitlab-runner
-pkgver=13.8.0
+pkgver=13.9.0
pkgrel=0
# first 8 chars of the git hash of the release, see
# https://gitlab.com/gitlab-org/gitlab-runner/-/tags
# PLEASE update this, since they're used to determine what version of
# https://hub.docker.com/r/gitlab/gitlab-runner-helper/tags to use
-_rev=775dd39d
+_rev=2ebc4dc4
pkgdesc="GitLab runner for CI/CD jobs"
url="https://docs.gitlab.com/runner/"
arch="all"
@@ -22,8 +22,6 @@ subpackages="$pkgname-helper $pkgname-openrc"
source="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$pkgver/gitlab-runner-v$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
- change-deps.patch
- fix-docker-linux-stat.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -68,8 +66,6 @@ helper() {
"$subpkgdir"/usr/bin/gitlab-runner-helper
}
-sha512sums="b7e14763d621ba641f90383c9d92d4302c808c6f84c9c915851f30c28fd6aca264c9410e2a2bb9d6c43619f8537b1c80dfabc66a6023747e8f9024629bd6f0b9 gitlab-runner-v13.8.0.tar.gz
+sha512sums="f3cde63f402ac3b618a5c106a2485d4687ddeb31730126a25786764f6c257c27009e05d996a37e6eef1f629884e25a5fa846fe871f724544bf3a5409aa0b6774 gitlab-runner-v13.9.0.tar.gz
2ae753efc220c46378e84831f01b289f3689af70cd7cbb0bbcc04dc17c910d65eb5105c198d5a23098e27797a7d1c695f49b244993ea4676eb9ec9cda064f44e gitlab-runner.initd
-243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445 gitlab-runner.confd
-b4ff8b577735df2905ba1cdc882e500315627504bdc82c7577b0cf2c0c59a62b2d92cb38c49093307900a11a9e1c67b717dc0bd6e728a00e8ee60df244cc4cbe change-deps.patch
-56b83d643062aeaa784fcf27e227a1f31b7e05df88ab8e900bc66916cef5eab35151c1dc2351187435838622dd58adb2c37b758afd13550cad42a171581dfa15 fix-docker-linux-stat.patch"
+243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445 gitlab-runner.confd"
diff --git a/community/gitlab-runner/change-deps.patch b/community/gitlab-runner/change-deps.patch
deleted file mode 100644
index e77db760a48..00000000000
--- a/community/gitlab-runner/change-deps.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff --git a/go.mod b/go.mod
-index 0652ef7..3bce4d0 100644
---- a/go.mod
-+++ b/go.mod
-@@ -11,6 +11,7 @@ require (
- github.com/Nvveen/Gotty v0.0.0-20120604004816-cd527374f1e5 // indirect
- github.com/ayufan/golang-kardianos-service v0.0.0-20160429143213-0c8eb6d8fff2
- github.com/bmatcuk/doublestar v1.3.0
-+ github.com/containerd/containerd v1.4.3 // indirect
- github.com/containerd/continuity v0.0.0-20181203112020-004b46473808 // indirect
- github.com/docker/cli v0.0.0-20181219132003-336b2a5cac7f
- github.com/docker/distribution v2.7.0+incompatible
-@@ -47,6 +48,7 @@ require (
- github.com/minio/md5-simd v1.1.1 // indirect
- github.com/minio/minio-go/v6 v6.0.57
- github.com/mitchellh/gox v1.0.1
-+ github.com/morikuni/aec v1.0.0 // indirect
- github.com/onsi/ginkgo v1.10.3 // indirect
- github.com/onsi/gomega v1.7.1 // indirect
- github.com/opencontainers/go-digest v1.0.0-rc1 // indirect
-@@ -88,6 +90,8 @@ require (
-
- replace golang.org/x/sys => golang.org/x/sys v0.0.0-20200826173525-f9321e4c35a6
-
--replace github.com/docker/docker v1.4.2-0.20190822180741-9552f2b2fdde => github.com/docker/engine v1.4.2-0.20190822180741-9552f2b2fdde
-+replace github.com/docker/docker v1.4.2-0.20190822180741-9552f2b2fdde => github.com/docker/engine v17.12.0-ce-rc1.0.20200514230353-811a247d06e8+incompatible
-
- replace github.com/minio/go-homedir v0.0.0-20190425115525-017018655514 => gitlab.com/steveazz/go-homedir v0.0.0-20190425115525-017018655514
-+
-+replace github.com/vishvananda/netns => github.com/vishvananda/netns v0.0.0-20200218060606-52d707b772fe
-diff --git a/go.sum b/go.sum
-index bab9cec..96f4729 100644
---- a/go.sum
-+++ b/go.sum
-@@ -124,6 +124,8 @@ github.com/chzyer/test v0.0.0-20180213035817-a1ea475d72b1/go.mod h1:Q3SI9o4m/ZMn
- github.com/client9/misspell v0.3.4/go.mod h1:qj6jICC3Q7zFZvVWo7KLAzC3yx5G7kyvSDkc90ppPyw=
- github.com/cncf/udpa/go v0.0.0-20191209042840-269d4d468f6f/go.mod h1:M8M6+tZqaGXZJjfX53e64911xZQV5JYwmTeXPW+k8Sc=
- github.com/cncf/udpa/go v0.0.0-20200629203442-efcf912fb354/go.mod h1:WmhPx2Nbnhtbo57+VJT5O0JRkEi1Wbu0z5j0R8u5Hbk=
-+github.com/containerd/containerd v1.4.3 h1:ijQT13JedHSHrQGWFcGEwzcNKrAGIiZ+jSD5QQG07SY=
-+github.com/containerd/containerd v1.4.3/go.mod h1:bC6axHOhabU15QhwfG7w5PipXdVtMXFTttgp+kVtyUA=
- github.com/containerd/continuity v0.0.0-20181203112020-004b46473808 h1:4BX8f882bXEDKfWIf0wa8HRvpnBoPszJJXL+TVbBw4M=
- github.com/containerd/continuity v0.0.0-20181203112020-004b46473808/go.mod h1:GL3xCUCBDV3CZiTSEKksMWbLE66hEyuu9qyDOOqM47Y=
- github.com/davecgh/go-spew v0.0.0-20161028175848-04cdfd42973b/go.mod h1:J7Y8YcW2NihsgmVo/mv3lAwl/skON4iLHjSsI+c5H38=
-@@ -146,6 +148,8 @@ github.com/docker/docker-credential-helpers v0.4.1 h1:ctHYuzQopMGaPgNpgBn0xiY/Tq
- github.com/docker/docker-credential-helpers v0.4.1/go.mod h1:WRaJzqw3CTB9bk10avuGsjVBZsD05qeibJ1/TYlvc0Y=
- github.com/docker/engine v1.4.2-0.20190822180741-9552f2b2fdde h1:aq0cubQTR2dVP78fiRSh2GfLAuadJ2DdGHKR66Jdmls=
- github.com/docker/engine v1.4.2-0.20190822180741-9552f2b2fdde/go.mod h1:3CPr2caMgTHxxIAZgEMd3uLYPDlRvPqCpyeRf6ncPcY=
-+github.com/docker/engine v17.12.0-ce-rc1.0.20200514230353-811a247d06e8+incompatible h1:bfMxnwcVz7E94VNnHW0Z/KhQR1dj8Awk0nZD4YWB7Ok=
-+github.com/docker/engine v17.12.0-ce-rc1.0.20200514230353-811a247d06e8+incompatible/go.mod h1:3CPr2caMgTHxxIAZgEMd3uLYPDlRvPqCpyeRf6ncPcY=
- github.com/docker/go-connections v0.3.0 h1:3lOnM9cSzgGwx8VfK/NGOW5fLQ0GjIlCkaktF+n1M6o=
- github.com/docker/go-connections v0.3.0/go.mod h1:Gbd7IOopHjR8Iph03tsViu4nIes5XhDvyHbTtUxmeec=
- github.com/docker/go-metrics v0.0.0-20181218153428-b84716841b82 h1:X0fj836zx99zFu83v/M79DuBn84IL/Syx1SY6Y5ZEMA=
-@@ -435,6 +439,8 @@ github.com/modern-go/concurrent v0.0.0-20180306012644-bacd9c7ef1dd/go.mod h1:6dJ
- github.com/modern-go/reflect2 v0.0.0-20180701023420-4b7aa43c6742/go.mod h1:bx2lNnkwVCuqBIxFjflWJWanXIb3RllmbCylyMrvgv0=
- github.com/modern-go/reflect2 v1.0.1 h1:9f412s+6RmYXLWZSEzVVgPGK7C2PphHj5RJrvfx9AWI=
- github.com/modern-go/reflect2 v1.0.1/go.mod h1:bx2lNnkwVCuqBIxFjflWJWanXIb3RllmbCylyMrvgv0=
-+github.com/morikuni/aec v1.0.0 h1:nP9CBfwrvYnBRgY6qfDQkygYDmYwOilePFkwzv4dU8A=
-+github.com/morikuni/aec v1.0.0/go.mod h1:BbKIizmSmc5MMPqRYbxO4ZU0S0+P200+tUnFx7PXmsc=
- github.com/mwitkow/go-conntrack v0.0.0-20161129095857-cc309e4a2223/go.mod h1:qRWi+5nqEBWmkhHvq77mSJWrCKwh8bxhgT7d/eI7P4U=
- github.com/niemeyer/pretty v0.0.0-20200227124842-a10e7caefd8e h1:fD57ERR4JtEqsWbfPhv4DMiApHyliiK5xCTNVSPiaAs=
- github.com/niemeyer/pretty v0.0.0-20200227124842-a10e7caefd8e/go.mod h1:zD1mROLANZcx1PVRCS0qkT7pwLkGfwJo4zjcN/Tysno=
diff --git a/community/gitlab-runner/fix-docker-linux-stat.patch b/community/gitlab-runner/fix-docker-linux-stat.patch
deleted file mode 100644
index e3e119c1faf..00000000000
--- a/community/gitlab-runner/fix-docker-linux-stat.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/vendor/github.com/docker/docker/pkg/system/stat_linux.go b/vendor/github.com/docker/docker/pkg/system/stat_linux.go
-index 98c9eb1..8a090a5 100644
---- a/vendor/github.com/docker/docker/pkg/system/stat_linux.go
-+++ b/vendor/github.com/docker/docker/pkg/system/stat_linux.go
-@@ -8,7 +8,7 @@ func fromStatT(s *syscall.Stat_t) (*StatT, error) {
- mode: s.Mode,
- uid: s.Uid,
- gid: s.Gid,
-- rdev: s.Rdev,
-+ rdev: uint64(s.Rdev),
- mtim: s.Mtim}, nil
- }
-