aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-04-14 15:21:11 +0200
committerBart Ribbers <bribbers@disroot.org>2021-04-14 14:20:40 +0000
commit6771cf120df2511fef96d57837f91aa01b7cae2f (patch)
treecb3014a21e0a1b9c6a303456c51376a38dc39927
parent09e171dd997838752fc6f8f29f6905871d9ccdb5 (diff)
testing/glacier-home: new aport
-rw-r--r--testing/glacier-home/APKBUILD55
-rw-r--r--testing/mapplauncherd-booster-qtcomponents/APKBUILD33
-rw-r--r--testing/mapplauncherd-booster-qtcomponents/fix-deprecated-qt.patch210
-rw-r--r--testing/mapplauncherd-booster-qtcomponents/fix-musl-incompability.patch102
-rw-r--r--testing/mapplauncherd-booster-qtcomponents/fix-wrong-include.patch12
5 files changed, 55 insertions, 357 deletions
diff --git a/testing/glacier-home/APKBUILD b/testing/glacier-home/APKBUILD
new file mode 100644
index 00000000000..484dee057f6
--- /dev/null
+++ b/testing/glacier-home/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=glacier-home
+pkgver=0.27.8_git20210325
+pkgrel=0
+_commit="656c70d9b6018f66ebf9d56ca8d3c10cf3187ca2"
+pkgdesc="The Glacier homescreen"
+url="https://github.com/nemomobile-ux/glacier-home"
+arch="all"
+license="BSD-3-Clause AND MIT"
+depends="
+ connman
+ libqofonoext
+ nemo-qml-plugin-configuration
+ nemo-qml-plugin-connectivity
+ nemo-qml-plugin-contacts
+ nemo-qml-plugin-devicelock
+ nemo-qml-plugin-notifications
+ nemo-qml-plugin-statusnotifier
+ nemo-qml-plugin-time
+ qt5-qtfeedback
+ qt5-qtgraphicaleffects
+ qt5-qtmultimedia
+ qtmpris
+ qtquickcontrols-nemo
+ "
+makedepends="
+ bluez-qt-dev
+ extra-cmake-modules
+ lipstick
+ nemo-qml-plugin-devicelock-dev
+ qt5-qtbase-dev
+ qt5-qtdeclarative-dev
+ qt5-qttools-dev
+ qt5-qtwayland-dev
+ "
+source="https://github.com/nemomobile-ux/glacier-home/archive/$_commit/glacier-home-$_commit.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/$pkgname-$_commit"
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DUSE_SYSTEMD=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="728007e9e3175587cc5f891ba8a9d4cded1ac7dcfc904d9818b76fe2f802a5d6dc567536f6da5495a492ad9ae2bdb71af299e44c028f2b6838b7e39e1522f164 glacier-home-656c70d9b6018f66ebf9d56ca8d3c10cf3187ca2.tar.gz"
diff --git a/testing/mapplauncherd-booster-qtcomponents/APKBUILD b/testing/mapplauncherd-booster-qtcomponents/APKBUILD
deleted file mode 100644
index 42f3153edc0..00000000000
--- a/testing/mapplauncherd-booster-qtcomponents/APKBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=mapplauncherd-booster-qtcomponents
-pkgver=0.1.1
-_pkgver=$pkgver+git1
-pkgrel=0
-pkgdesc="A daemon that helps to launch applications faster"
-url="https://git.sailfishos.org/mer-core/mapplauncherd-booster-qtcomponents"
-arch="all"
-license="LGPL-2.1-only"
-depends_dev="
- mapplauncherd-qt-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- "
-makedepends="$depends_dev"
-source="https://git.sailfishos.org/mer-core/mapplauncherd-booster-qtcomponents/-/archive/$_pkgver/mapplauncherd-booster-qtcomponents-$_pkgver.tar.gz"
-options="!check" # No tests
-builddir="$srcdir/$pkgname-$_pkgver"
-
-build() {
- qmake-qt5
- make
-}
-
-package() {
- INSTALL_ROOT="$pkgdir" make install
-
- # We don't have systemd
- rm -r "$pkgdir"/usr/lib/systemd
-}
-
-sha512sums="7b6d9b531b24016f3b36b514e39305f4f00c3ca6975e3a0a7aa21c3f05d298fdf4dd8b6410c2076a9af9d66572ae828d16248fd81fa0ef4f872a090640220652 mapplauncherd-booster-qtcomponents-0.1.1+git1.tar.gz"
diff --git a/testing/mapplauncherd-booster-qtcomponents/fix-deprecated-qt.patch b/testing/mapplauncherd-booster-qtcomponents/fix-deprecated-qt.patch
deleted file mode 100644
index 9233de3feed..00000000000
--- a/testing/mapplauncherd-booster-qtcomponents/fix-deprecated-qt.patch
+++ /dev/null
@@ -1,210 +0,0 @@
-diff --git a/benchmarks/pt_mlocale/pt_mlocale.cpp b/benchmarks/pt_mlocale/pt_mlocale.cpp
-index 40c24827..709d5859 100644
---- a/benchmarks/pt_mlocale/pt_mlocale.cpp
-+++ b/benchmarks/pt_mlocale/pt_mlocale.cpp
-@@ -249,8 +249,8 @@ void Pt_MLocale::benchmarkChineseSorting()
- QString str("居 于 中 国 疆 域 内 的 各 个 民 族 统 称 为 中 华 民 族 亦 称 中 国 人 或 华 人 华 族 移 居 境 外 的 华 人 多 被 称 为 海 外 华 人 汉 族 是 中 国 人 口 最 多 地 域 分 布 最 广 的 民 族 在 少 数 民 族 当 中 人 过 年 口 查 有 满 苗 吾 彝 家 古 藏 9 民 通 汉 少 民 地 往 使 各 族 己 语 中 的 统 术 式 国 戏 书 和 画 传 娱 活 有 棋 棋 麻 等 国 格 术 术 世 名 酒 和 子 为 国 特 饮 文 春 中 新 元 清 端 七 中 重 冬 等 传 节 中 传 上 一 儒 思 国 中 人 强 的 庭 念 此 代 家 的 氏 于 名 前 国 还 视 育 对 才 选 春 时 孔 有 无 因 施 开 办 塾 养 才 朝 采 察 推 政 官 隋 起 行 举 平 中 拔 才 古 来 文 科 技 等 面 成 浩 烟 明 以 西 的 代 技 民 政 思 传 中 中 歷 重 編 历 历 历 都 有 官 此 存 十 详 的 史 料 二 四 资 通 等 今 4 0 多 前 中 地 为 心 始 现 落 织 而 国 和 代 历 多 演 和 代 迭 续 间 长 朝 有 商 汉 宋 和 等 朝 代 出 过 平 世 汉 文 之 和 武 兴 朝 观 治 开 盛 明 万 中 清 康 盛 等 學 究 示 國 代 更 常 氣 與 食 產 影 会 致 在 乱 分 时 中 王 历 上 断 北 游 民 交 征 如 奴 厥 卑 古 女 满 等 中 晋 代 经 五 乱 而 古 女 甚 入 中 改 了 国 世 的 史 展 程 多 族 入 华 族 大 庭 亥 命 中 的 王 体 1 1 年 出 史 台 而 之 是 和 体 中 民 後 国 内 時 民 府 臺 形 中 民 實 統 台 地 與 生 權 华 民 和 實 統 大 地 分 的 面 居 于 中 国 疆 域 内 的 各 个 民 族 统 称 为 中 华 民 族 亦 称 中 国 人 或 华 人 华 族 移 居 境 外 的 华 人 多 被 称 为 海 外 华 人 汉 族 是 中 国 人 口 最 多 地 域 分 布 最 广 的 民 族 在 少 数 民 族 当 中 人 过 年 口 查 有 满 苗 吾 彝 家 古 藏 9 民 通 汉 少 民 地 往 使 各 族 己 语 中 的 统 术 式 国 戏 书 和 画 传 娱 活 有 棋 棋 麻 等 国 格 术 术 世 名 酒 和 子 为 国 特 饮 文 春 中 新 元 清 端 七 中 重 冬 等 传 节 中 传 上 一 儒 思 国 中 人 强 的 庭 念 此 代 家 的 氏 于 名 前 国 还 视 育 对 才 选 春 时 孔 有 无 因 施 开 办 塾 养 才 朝 采 察 推 政 官 隋 起 行 举 平 中 拔 才 古 来 文 科 技 等 面 成 浩 烟 明 以 西 的 代 技 民 政 思 传 中 中 歷 重 編 历 历 历 都 有 官 此 存 十 详 的 史 料 二 四 资 通 等 今 4 0 多 前 中 地 为 心 始 现 落 织 而 国 和 代 历 多 演 和 代 迭 续 间 长 朝 有 商 汉 宋 和 等 朝 代 出 过 平 世 汉 文 之 和 武 兴 朝 观 治 开 盛 明 万 中 清 康 盛 等 學 究 示 國 代 更 常 氣 與 食 產 影 会 致 在 乱 分 时 中 王 历 上 断 北 游 民 交 征 如 奴 厥 卑 古 女 满 等 中 晋 代 经 五 乱 而 古 女 甚 入 中 改 了 国 世 的 史 展 程 多 族 入 华 族 大 庭 亥 命 中 的 王 体 1 1 年 出 史 台 而 之 是 和 体 中 民 後 国 内 時 民 府 臺 形 中 民 實 統 台 地 與 生 權 华 民 和 實 統 大 地 分 的 面");
- QStringList list = str.split(QLatin1String(" "),QString::SkipEmptyParts);
- QBENCHMARK {
-- qSort (list.begin(), list.end(), localeEn.collator());
-- qSort (list.begin(), list.end(), localeZh.collator());
-+ std::sort (list.begin(), list.end(), localeEn.collator());
-+ std::sort (list.begin(), list.end(), localeZh.collator());
- }
- }
- #endif
-diff --git a/doc/src/i18n.dox b/doc/src/i18n.dox
-index 02a44a9f..53050896 100644
---- a/doc/src/i18n.dox
-+++ b/doc/src/i18n.dox
-@@ -157,10 +157,10 @@ MLocale locale ("fi_FI");
- where "fi" and "FI" define that the Finnish language in used in Finland.
-
- \subsection Collator Collator
--To collate, get the comparator with \c MLocale::collator() method or create it MCollator() for default locale collator. This object acts as a functor and can be passed to Qt's \c qSort() or any other sorting methods.
-+To collate, get the comparator with \c MLocale::collator() method or create it MCollator() for default locale collator. This object acts as a functor and can be passed to std::sort() or any other sorting methods.
- The comparator basically compares two items as "lessThan" function and returns true if the first parameter should come before the second one.
-
--If some other collation system than the locale's default is needed, use \c setCollation() method before getting the comparator. To start sorting, use Qt's \c qSort() function.
-+If some other collation system than the locale's default is needed, use \c setCollation() method before getting the comparator. To start sorting, use std::sort() function.
-
- To use the default collation system:
- \code
-@@ -169,7 +169,7 @@ QStringList sl; // This contains the strings which need to be sorted
- MLocale myLocale; // get the current locale
- MCollator c = myLocale.collator(); // getting the comparator
- ...
--qSort(sl.begin, sl.end, c); // start to sort!
-+std::sort(sl.begin, sl.end, c); // start to sort!
- ...
- \endcode
-
-@@ -190,7 +190,7 @@ MLocale myLocale("de_DE@collation=phonebook");
-
- MCollator c = myLocale.collator(); // getting the comparator
- ...
--qSort(sl.begin, sl.end, c); // start to sort!
-+std::sort(sl.begin, sl.end, c); // start to sort!
- ...
- \endcode
-
-diff --git a/src/mcharsetdetector.cpp b/src/mcharsetdetector.cpp
-index 8ee73134..9d21d341 100644
---- a/src/mcharsetdetector.cpp
-+++ b/src/mcharsetdetector.cpp
-@@ -484,8 +484,8 @@ QList<MCharsetMatch> MCharsetDetector::detectAll()
- }
- // sort the list of matches again if confidences have been changed:
- if(sortNeeded)
-- qSort(mCharsetMatchList.begin(), mCharsetMatchList.end(),
-- qGreater<MCharsetMatch>());
-+ std::sort(mCharsetMatchList.begin(), mCharsetMatchList.end(),
-+ std::greater<MCharsetMatch>());
- if(mCharsetMatchList.isEmpty()) {
- // is there any better status to describe this case?
- d->_status = U_CE_NOT_FOUND_ERROR;
-@@ -677,7 +677,7 @@ QStringList MCharsetDetector::getAllDetectableCharsets()
- d->_allDetectableCharsets << cs;
- }
-
-- qSort(d->_allDetectableCharsets);
-+ std::sort(d->_allDetectableCharsets.begin(), d->_allDetectableCharsets.end());
-
- return d->_allDetectableCharsets;
- }
-diff --git a/src/mcollator.cpp b/src/mcollator.cpp
-index 4d3613d7..c27e8c82 100644
---- a/src/mcollator.cpp
-+++ b/src/mcollator.cpp
-@@ -79,7 +79,7 @@ void MCollatorPrivate::initCollator(const icu::Locale &locale)
- QStringList stringList;
- stringList << "bb" << "da" << "aa" << "ab";
-
-- qSort(stringList.begin(), stringList.end(), comp); // sorts the list
-+ std::sort(stringList.begin(), stringList.end(), comp); // sorts the list
- \endverbatim
-
- */
-diff --git a/src/mlocalebuckets.cpp b/src/mlocalebuckets.cpp
-index 5c1aa4b9..e7f54e97 100644
---- a/src/mlocalebuckets.cpp
-+++ b/src/mlocalebuckets.cpp
-@@ -43,7 +43,7 @@ void MLocaleBucketsPrivate::setItems(const QStringList &unsortedItems, Qt::SortO
- for (int i=0; i < unsortedItems.size(); ++i) {
- items.append(MLocaleBucketItem(unsortedItems.at(i), i));
- }
-- qStableSort(items.begin(), items.end(), MLocaleBucketItemComparator(sortOrder));
-+ std::stable_sort(items.begin(), items.end(), MLocaleBucketItemComparator(sortOrder));
-
- QString lastBucket;
- QStringList lastBucketItems;
-diff --git a/src/mlocalebuckets_p.h b/src/mlocalebuckets_p.h
-index 42d35331..dea49819 100644
---- a/src/mlocalebuckets_p.h
-+++ b/src/mlocalebuckets_p.h
-@@ -75,7 +75,7 @@ struct MLocaleBucketItem
-
-
-
--// Functor for qStableSort() comparison
-+// Functor for std::stable_sort() comparison
- class MLocaleBucketItemComparator
- {
- public:
-diff --git a/tests/ft_locales/ft_locales.cpp b/tests/ft_locales/ft_locales.cpp
-index 36d5fb91..8277c57e 100644
---- a/tests/ft_locales/ft_locales.cpp
-+++ b/tests/ft_locales/ft_locales.cpp
-@@ -3902,9 +3902,9 @@ void Ft_Locales::testMLocaleIndexBucket()
- MLocale localeEn("en_US");
- locale.setCategoryLocale(MLocale::MLcCollate, lcCollate);
- QStringList stringsSortedCopy = stringsSorted;
-- qSort (stringsSortedCopy.begin(), stringsSortedCopy.end(),
-+ std::sort (stringsSortedCopy.begin(), stringsSortedCopy.end(),
- localeEn.collator());
-- qSort (stringsSortedCopy.begin(), stringsSortedCopy.end(),
-+ std::sort (stringsSortedCopy.begin(), stringsSortedCopy.end(),
- locale.collator());
- #if defined(VERBOSE_OUTPUT)
- QTextStream debugStream(stdout);
-@@ -4407,7 +4407,7 @@ void Ft_Locales::checkAvailableLocales()
- supportedLocaleNames.append(numberSystemTestLocales);
- // sort the list for easier comparison in the output
- // (i.e. es_419 should be near es, not at the end of the list):
-- qSort(supportedLocaleNames.begin(), supportedLocaleNames.end());
-+ std::sort(supportedLocaleNames.begin(), supportedLocaleNames.end());
- MCalendar::setSystemTimeZone("GMT+0");
- QDateTime dateTime(QDate(2008, 7, 21), QTime(14, 31, 0, 0), Qt::LocalTime);
- MCalendar gregorianCalendar(MLocale::GregorianCalendar);
-@@ -4471,7 +4471,7 @@ void Ft_Locales::checkAvailableLocales()
- QCOMPARE(MLocale::dataPaths(), (QStringList() << "/usr/share/mlocale5/icu"));
- locale.setTimeFormat24h(MLocale::LocaleDefaultTimeFormat24h);
- QCOMPARE(locale.timeFormat24h(), MLocale::LocaleDefaultTimeFormat24h);
-- qSort(sortingTestList.begin(), sortingTestList.end(), locale.collator());
-+ std::sort(sortingTestList.begin(), sortingTestList.end(), locale.collator());
- QString newLinePlusSupportedLocaleName('\n' + supportedLocaleName);
- ft_localesTestOutput
- += supportedLocaleName + "\tLanguage endonym\t"
-diff --git a/tests/ft_mcharsetdetector/ft_mcharsetdetector.cpp b/tests/ft_mcharsetdetector/ft_mcharsetdetector.cpp
-index a7395df4..0d9c5592 100644
---- a/tests/ft_mcharsetdetector/ft_mcharsetdetector.cpp
-+++ b/tests/ft_mcharsetdetector/ft_mcharsetdetector.cpp
-@@ -90,8 +90,8 @@ void Ft_MCharsetDetector::testMCharsetMatch()
- match.setConfidence(confidencesSorted[i].toInt());
- mCharsetMatchListSorted << match;
- }
-- qSort(mCharsetMatchList.begin(), mCharsetMatchList.end(),
-- qGreater<MCharsetMatch>());
-+ std::sort(mCharsetMatchList.begin(), mCharsetMatchList.end(),
-+ std::greater<MCharsetMatch>());
- #if defined(VERBOSE_OUTPUT)
- for(int i = 0; i < names.size(); ++i) {
- qDebug() << mCharsetMatchList[i].name()
-diff --git a/tests/ft_sorting/ft_sorting.cpp b/tests/ft_sorting/ft_sorting.cpp
-index df142dc9..4190aa6a 100644
---- a/tests/ft_sorting/ft_sorting.cpp
-+++ b/tests/ft_sorting/ft_sorting.cpp
-@@ -412,7 +412,7 @@ void Ft_Sorting::testMLocaleSorting()
- #if defined(VERBOSE_OUTPUT)
- printf("%s %s %s %s %s\n", sl[0].toUtf8().data(), sl[1].toUtf8().data(), sl[2].toUtf8().data(), sl[3].toUtf8().data(), sl[4].toUtf8().data());
- #endif
-- qSort(sl.begin(), sl.end(), mCollator);
-+ std::sort(sl.begin(), sl.end(), mCollator);
- #if defined(VERBOSE_OUTPUT)
- printf("%s %s %s %s %s\n", sl[0].toUtf8().data(), sl[1].toUtf8().data(), sl[2].toUtf8().data(), sl[3].toUtf8().data(), sl[4].toUtf8().data());
- #endif
-@@ -424,18 +424,18 @@ void Ft_Sorting::testMLocaleSorting()
-
- MCollator mCollatorDefaultLocale;
- QStringList sl2 = stringListOrig;
-- qSort(sl2.begin(), sl2.end(), mCollatorDefaultLocale);
-+ std::sort(sl2.begin(), sl2.end(), mCollatorDefaultLocale);
- QCOMPARE(sl2, sl);
-
- TestCollator *testCollator = new TestCollator(locale);
- sl2 = stringListOrig;
-- qSort(sl2.begin(), sl2.end(), *testCollator);
-+ std::sort(sl2.begin(), sl2.end(), *testCollator);
- QCOMPARE(sl2, sl);
- delete testCollator;
-
- TestCollator *testCollatorDefaultLocale = new TestCollator();
- sl2 = stringListOrig;
-- qSort(sl2.begin(), sl2.end(), *testCollatorDefaultLocale);
-+ std::sort(sl2.begin(), sl2.end(), *testCollatorDefaultLocale);
- QCOMPARE(sl2, sl);
- delete testCollatorDefaultLocale;
- }
-diff --git a/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp b/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp
-index a5a0e316..5a3131f5 100644
---- a/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp
-+++ b/tests/ut_mlocationdatabase/ut_mlocationdatabase.cpp
-@@ -723,7 +723,7 @@ void Ut_MLocationDatabase::testCitiesDumpInfo()
- + gmtTotalOffsetSummer
- + ")\"\n";
- }
-- qSort(ut_mlocationdatabaseTestOutput2Lines.begin(), ut_mlocationdatabaseTestOutput2Lines.end());
-+ std::sort(ut_mlocationdatabaseTestOutput2Lines.begin(), ut_mlocationdatabaseTestOutput2Lines.end());
- QString ut_mlocationdatabaseTestOutput2 = "";
- foreach (QString line, ut_mlocationdatabaseTestOutput2Lines) {
- ut_mlocationdatabaseTestOutput2 += line;
diff --git a/testing/mapplauncherd-booster-qtcomponents/fix-musl-incompability.patch b/testing/mapplauncherd-booster-qtcomponents/fix-musl-incompability.patch
deleted file mode 100644
index ebc0dcc54c3..00000000000
--- a/testing/mapplauncherd-booster-qtcomponents/fix-musl-incompability.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-diff --git a/src/invoker/CMakeLists.txt b/src/invoker/CMakeLists.txt
-index 6531ca0..3a35a6b 100644
---- a/src/invoker/CMakeLists.txt
-+++ b/src/invoker/CMakeLists.txt
-@@ -19,6 +19,6 @@ add_executable(invoker ${SRC})
- target_link_libraries(invoker ${DBUS_LDFLAGS})
-
- # Add install rule
--install(PROGRAMS invoker DESTINATION /usr/bin/)
-+install(TARGETS invoker DESTINATION /usr/bin/)
-
-
-diff --git a/src/launcherlib/CMakeLists.txt b/src/launcherlib/CMakeLists.txt
-index 3d986ca..89eacd1 100644
---- a/src/launcherlib/CMakeLists.txt
-+++ b/src/launcherlib/CMakeLists.txt
-@@ -1,6 +1,11 @@
- set(COMMON ${CMAKE_HOME_DIRECTORY}/src/common)
-
--include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${COMMON})
-+# Find systemd
-+find_package(PkgConfig REQUIRED)
-+pkg_check_modules(SYSTEMD "libsystemd" REQUIRED)
-+
-+# Set include dirs
-+include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${SYSTEMD_INCLUDE_DIRS} ${COMMON})
-
- # Hide all symbols except the ones explicitly exported in the code (like main())
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility=hidden")
-@@ -12,14 +17,13 @@ set(SRC appdata.cpp booster.cpp connection.cpp daemon.cpp logger.cpp
- set(HEADERS appdata.h booster.h connection.h daemon.h logger.h launcherlib.h
- singleinstance.h socketmanager.h ${COMMON}/protocol.h)
-
--# Set libraries to be linked. Shared libraries to be preloaded are not linked in anymore,
--# but dlopen():ed and listed in src/launcher/preload.h instead.
--link_libraries(${LIBDL} "-L/lib -lsystemd")
--
- # Set executable
- add_library(applauncherd MODULE ${SRC} ${MOC_SRC})
- set_target_properties(applauncherd PROPERTIES VERSION 0.1 SOVERSION 0)
-
-+target_link_libraries(applauncherd ${SYSTEMD_LIBRARIES})
-+
-+
- # Add install rule
- install(TARGETS applauncherd DESTINATION /usr/lib)
- install(FILES ${HEADERS} DESTINATION /usr/include/applauncherd
-diff --git a/src/launcherlib/booster.cpp b/src/launcherlib/booster.cpp
-index 235f2a0..5645e6a 100644
---- a/src/launcherlib/booster.cpp
-+++ b/src/launcherlib/booster.cpp
-@@ -46,6 +46,7 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <grp.h>
-+#include <libgen.h>
-
- #include "coverage.h"
-
-@@ -327,7 +328,7 @@ void Booster::renameProcess(int parentArgc, char** parentArgv,
- }
-
- // Set the process name using prctl, 'killall' and 'top' use it
-- if ( prctl(PR_SET_NAME, basename(sourceArgv[0])) == -1 )
-+ if ( prctl(PR_SET_NAME, basename(const_cast<char*>(sourceArgv[0]))) == -1 )
- Logger::logError("Booster: on set new process name: %s ", strerror(errno));
-
- setenv("_", sourceArgv[0], true);
-@@ -583,7 +584,7 @@ void* Booster::loadMain()
- else
- dlopenFlags |= RTLD_LOCAL;
-
--#if (PLATFORM_ID == Linux)
-+#if (PLATFORM_ID == Linux) && defined(__GLIBC__)
- if (m_appData->dlopenDeep())
- dlopenFlags |= RTLD_DEEPBIND;
- #endif
-diff --git a/src/launcherlib/connection.cpp b/src/launcherlib/connection.cpp
-index b5dd89d..352704b 100644
---- a/src/launcherlib/connection.cpp
-+++ b/src/launcherlib/connection.cpp
-@@ -281,8 +281,8 @@ bool Connection::receiveArgs()
- {
- // Get argc
- recvMsg(&m_argc);
-- const uint32_t ARG_MAX = 1024;
-- if (m_argc > 0 && m_argc < ARG_MAX)
-+ const uint32_t _ARG_MAX = 1024;
-+ if (m_argc > 0 && m_argc < _ARG_MAX)
- {
- // Reserve memory for argv
- m_argv = new const char * [m_argc];
-diff --git a/src/single-instance/CMakeLists.txt b/src/single-instance/CMakeLists.txt
-index cc04ba2..acc1439 100644
---- a/src/single-instance/CMakeLists.txt
-+++ b/src/single-instance/CMakeLists.txt
-@@ -26,4 +26,4 @@ link_libraries(${DBUS_LDFLAGS})
- add_executable(single-instance ${SRC})
-
- # Add install rule
--install(PROGRAMS single-instance DESTINATION /usr/bin/)
-+install(TARGETS single-instance DESTINATION /usr/bin/)
diff --git a/testing/mapplauncherd-booster-qtcomponents/fix-wrong-include.patch b/testing/mapplauncherd-booster-qtcomponents/fix-wrong-include.patch
deleted file mode 100644
index 3b20a39cd5c..00000000000
--- a/testing/mapplauncherd-booster-qtcomponents/fix-wrong-include.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/invoker/invoker.c b/src/invoker/invoker.c
-index ba81f7b..1a806d9 100644
---- a/src/invoker/invoker.c
-+++ b/src/invoker/invoker.c
-@@ -26,7 +26,6 @@
- #include <string.h>
- #include <signal.h>
- #include <sys/socket.h>
--#include <bits/socket.h>
- #include <sys/un.h>
- #include <sys/uio.h>
- #include <sys/time.h>