aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-10 07:45:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-10 11:48:12 +0000
commit688185b826de2598daff359b224f44529ab7a8ba (patch)
treed4ab3acb6c43fa24d449c4de2f360cbb1d66589a
parente34b0c0f322a7c669d2ff7be52d75f58bd779cd0 (diff)
main/pcre2: upgrade to 10.35
-rw-r--r--main/pcre2/APKBUILD11
-rw-r--r--main/pcre2/fix-rspamd-segfault.patch34
2 files changed, 4 insertions, 41 deletions
diff --git a/main/pcre2/APKBUILD b/main/pcre2/APKBUILD
index 7833d43d66b..f345d9e0330 100644
--- a/main/pcre2/APKBUILD
+++ b/main/pcre2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pcre2
-pkgver=10.34
-pkgrel=1
+pkgver=10.35
+pkgrel=0
pkgdesc="Perl-compatible regular expression library"
url="https://pcre.org/"
arch="all"
@@ -11,9 +11,7 @@ depends_dev="libedit-dev zlib-dev"
makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
libpcre2-16:_libpcre libpcre2-32:_libpcre"
-source="https://ftp.pcre.org/pub/pcre/pcre2-$pkgver.tar.gz
- fix-rspamd-segfault.patch
- "
+source="https://ftp.pcre.org/pub/pcre/pcre2-$pkgver.tar.gz"
case "$CARCH" in
s390x|armhf) _enable_jit="";; # https://bugs.exim.org/show_bug.cgi?id=2468
@@ -72,5 +70,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="820b3805fc7fcf3a80dfd42ff570efc8518fe3c50f3feb720319b95316619e5b8f6601b3c9522606315aecd5558ccfc8a04a89fab9921fdfc3400dc2caf17c22 pcre2-10.34.tar.gz
-571e89a3dc74a3e6b52fe9c8083df79a72a6430849a7ffe887fed832c8d40537554ac8ee29c42b3c1f212ad13f0326b9c5d9305d0dd889be10ed25b1cc6992b6 fix-rspamd-segfault.patch"
+sha512sums="f9386de9211919da68ad0882dbfb72b344306280b3c4515f496cff4e3ff5c11e29fb71539a357a43a71ef668a742a54cc327a1dc3a00c767fbd0264933beecee pcre2-10.35.tar.gz"
diff --git a/main/pcre2/fix-rspamd-segfault.patch b/main/pcre2/fix-rspamd-segfault.patch
deleted file mode 100644
index e4bd828fab9..00000000000
--- a/main/pcre2/fix-rspamd-segfault.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From: zherczeg
-Date: Sat, 7 Dec 2019 16:00:53 +0000
-Subject: [PATCH] Fix the too early access of the fields of a compiled pattern in JIT
-
-Patch-Source: https://lists.exim.org/lurker/message/20191207.160053.4a30f0bc.hu.html
-
-diff --git a/src/pcre2_jit_compile.c b/src/pcre2_jit_compile.c
-index f564127..304c47a 100644
---- a/src/pcre2_jit_compile.c
-+++ b/src/pcre2_jit_compile.c
-@@ -13742,11 +13742,6 @@ pcre2_jit_compile(pcre2_code *code, uint32_t options)
- {
- pcre2_real_code *re = (pcre2_real_code *)code;
-
--#ifdef SUPPORT_JIT
--executable_functions *functions = (executable_functions *)re->executable_jit;
--static int executable_allocator_is_working = 0;
--#endif
--
- if (code == NULL)
- return PCRE2_ERROR_NULL;
-
-@@ -13779,6 +13774,11 @@ actions are needed:
- avoid compiler warnings.
- */
-
-+#ifdef SUPPORT_JIT
-+executable_functions *functions = (executable_functions *)re->executable_jit;
-+static int executable_allocator_is_working = 0;
-+#endif
-+
- if ((options & PCRE2_JIT_INVALID_UTF) != 0)
- {
- if ((re->overall_options & PCRE2_MATCH_INVALID_UTF) == 0)