aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-13 13:31:54 -0300
committerShiz <hi@shiz.me>2017-05-14 03:35:40 +0200
commit68c73099447753d9ac19ebe2ad76eff4bbce18c9 (patch)
tree6169c02e44edc0886d86b163a88292c81db2343f
parent673cacfbea8e17a416af43255dad9e332b4c0915 (diff)
community/moc: modernize abuild
-rw-r--r--community/moc/APKBUILD72
1 files changed, 30 insertions, 42 deletions
diff --git a/community/moc/APKBUILD b/community/moc/APKBUILD
index 837c9603690..54ac61de50d 100644
--- a/community/moc/APKBUILD
+++ b/community/moc/APKBUILD
@@ -7,59 +7,47 @@ pkgdesc="MOC is a console audio player"
url="http://moc.daper.net/"
arch="all"
license="GPL"
-depends=""
-depends_dev=""
makedepends="curl-dev libtool file ffmpeg-dev speex-dev alsa-lib-dev
- libmodplug-dev faad2-dev jack-dev libmad-dev ncurses-dev"
-install=""
+ libmodplug-dev faad2-dev jack-dev libmad-dev ncurses-dev"
subpackages="$pkgname-doc"
source="http://ftp.daper.net/pub/soft/moc/stable/moc-${pkgver}.tar.bz2"
-_builddir="${srcdir}/${pkgname}-${pkgver}"
+builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- update_config_sub || return 1
+ default_prepare
+ update_config_sub
}
build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --without-rcc \
- --with-oss \
- --with-alsa \
- --with-jack \
- --with-aac \
- --with-mp3 \
- --with-musepack \
- --with-vorbis \
- --with-flac \
- --with-wavpack \
- --with-sndfile \
- --with-modplug \
- --with-ffmpeg \
- --with-speex \
- --with-samplerate \
- --with-curl \
- --disable-cache \
- --disable-debug \
- || return 1
- make || return 1
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --without-rcc \
+ --with-oss \
+ --with-alsa \
+ --with-jack \
+ --with-aac \
+ --with-mp3 \
+ --with-musepack \
+ --with-vorbis \
+ --with-flac \
+ --with-wavpack \
+ --with-sndfile \
+ --with-modplug \
+ --with-ffmpeg \
+ --with-speex \
+ --with-samplerate \
+ --with-curl \
+ --disable-cache \
+ --disable-debug
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
-md5sums="48e5abcd5ffc76921d4feea8a1fc2dbb moc-2.5.2.tar.bz2"
-sha256sums="f3a68115602a4788b7cfa9bbe9397a9d5e24c68cb61a57695d1c2c3ecf49db08 moc-2.5.2.tar.bz2"
sha512sums="992d06809fb52e58dcee63704bde05795b99edbac46edd8381f314c564490013b18e1853926f419c2c3c7f1bb68ff35e97048de03ace3232b800cf4b3b7dbe0f moc-2.5.2.tar.bz2"