aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2021-03-25 14:08:37 +0100
committerRasmus Thomsen <oss@cogitri.dev>2021-03-25 15:08:20 +0100
commit7048d6f4f1c3ef769f5f9f40e5a016339e9e384a (patch)
treed31b2a2aa0e70d671fb25a6e718b77c92de86178
parent27711dc691539de4b6b60eea97cf486002715cb2 (diff)
community/gtksourceview5: new aport
https://wiki.gnome.org/Projects/GtkSourceView A text widget adding syntax highlighting and more to GNOME
-rw-r--r--community/gtksourceview5/APKBUILD35
-rw-r--r--community/gtksourceview5/skip-test.patch14
2 files changed, 49 insertions, 0 deletions
diff --git a/community/gtksourceview5/APKBUILD b/community/gtksourceview5/APKBUILD
new file mode 100644
index 00000000000..de56c51bf68
--- /dev/null
+++ b/community/gtksourceview5/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor:Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gtksourceview5
+pkgver=5.0.0
+pkgrel=0
+pkgdesc="A text widget adding syntax highlighting and more to GNOME"
+url="https://wiki.gnome.org/Projects/GtkSourceView"
+arch="all !mips64" # blocked by glade -> webkit2gtk
+license="GPL-2.0-or-later"
+depends_dev="gtk4.0-dev libxml2-dev"
+makedepends="$depends_dev gobject-introspection-dev vala libxslt meson glade-dev
+ pcre2-dev"
+checkdepends="xvfb-run ibus dbus"
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://download.gnome.org/sources/gtksourceview/${pkgver%.*}/gtksourceview-$pkgver.tar.xz
+ skip-test.patch
+ "
+builddir="$srcdir/gtksourceview-$pkgver"
+
+build() {
+ abuild-meson \
+ -Dglade_catalog=true \
+ . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
+}
+
+check() {
+ xvfb-run meson test --no-rebuild -v -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+sha512sums="6a5f66206bb59e153f18d61f085149ad96039866373c1ef159aaed4b125a64806d59b42b491b89564aa54b26e43abe43aad261e4e5f942eb63708f2e0a631614 gtksourceview-5.0.0.tar.xz
+c765c7c77a94007e95c050c05ef0283b2cdcd5751274924ea08a02ea2507061677d7f286c3e98d6b91f3603a06364d1ea43491e77e2e086e05c841218923e771 skip-test.patch"
diff --git a/community/gtksourceview5/skip-test.patch b/community/gtksourceview5/skip-test.patch
new file mode 100644
index 00000000000..9622cab208a
--- /dev/null
+++ b/community/gtksourceview5/skip-test.patch
@@ -0,0 +1,14 @@
+This test tries to access /var/lib/dbus/machine-id because of its usage of IBus.
+
+diff --git a/testsuite/meson.build b/testsuite/meson.build
+index f842a07..bd31ec8 100644
+--- a/testsuite/meson.build
++++ b/testsuite/meson.build
+@@ -34,7 +34,6 @@ testsuite_sources = [
+ ['test-styleschememanager'],
+ ['test-undo-manager'],
+ ['test-utils'],
+- ['test-view'],
+ ]
+
+ foreach test: testsuite_sources