aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Denes <caskd@redxen.eu>2020-09-05 00:28:27 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-09-22 17:10:34 -0300
commit70690ecaf7074f7527260fca1bbe40fded1abfb0 (patch)
tree1b18c1bd6dc5be69969098c2258a543e8699e074
parent5f34b969585aa8e2e2240f81aa26146e340cc86a (diff)
testing/multimc: new aport
Custom minecraft launcher that manages parallel installations https://github.com/MultiMC/MultiMC5
-rw-r--r--testing/multimc/01-patch-jar-path.patch14
-rw-r--r--testing/multimc/APKBUILD57
2 files changed, 71 insertions, 0 deletions
diff --git a/testing/multimc/01-patch-jar-path.patch b/testing/multimc/01-patch-jar-path.patch
new file mode 100644
index 00000000000..fb1f7f4d750
--- /dev/null
+++ b/testing/multimc/01-patch-jar-path.patch
@@ -0,0 +1,14 @@
+Upstream: No, should be if applicable
+Reason: Fixes location of JAR files
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -216,7 +216,7 @@
+ set(LIBRARY_DEST_DIR ${MultiMC_LIBRARY_DEST_DIR})
+
+ MESSAGE(STATUS "Compiling for linux system with ${MultiMC_SHARE_DEST_DIR} and MULTIMC_LINUX_DATADIR")
++ SET(MultiMC_APP_BINARY_DEFS "-DMULTIMC_JARS_LOCATION=/usr/${JARS_DEST_DIR}" "-DMULTIMC_LINUX_DATADIR")
+- SET(MultiMC_APP_BINARY_DEFS "-DMULTIMC_JARS_LOCATION=${CMAKE_INSTALL_PREFIX}/${JARS_DEST_DIR}" "-DMULTIMC_LINUX_DATADIR")
+
+ # install as bundle with no dependencies included
+ set(INSTALL_BUNDLE "nodeps")
diff --git a/testing/multimc/APKBUILD b/testing/multimc/APKBUILD
new file mode 100644
index 00000000000..5ac3c97cf2e
--- /dev/null
+++ b/testing/multimc/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Alex Denes <caskd@redxen.eu>
+# Maintainer: Alex Denes <caskd@redxen.eu>
+pkgname=multimc
+pkgver=0.6.11
+pkgrel=0
+pkgdesc="Custom minecraft launcher that manages parallel installations"
+url="https://github.com/MultiMC/MultiMC5"
+arch="x86 x86_64" # Officially supported
+license="MIT AND LGPL-2.0-or-later AND LGPL-2.1-only AND LGPL-2.1-or-later AND LGPL-3.0-or-later AND BSD-3-Clause-Clear AND OFL-1.0-RFN AND GPL-2.0 WITH Classpath-exception-2.0 AND Apache-2.0"
+depends="qt5-qtbase qt5-qtx11extras qt5-qtsvg openjdk8-jre"
+makedepends="
+ cmake
+ qt5-qtbase-dev
+ qt5-qtx11extras-dev
+ zlib-dev
+ openjdk8
+"
+_libnbtpluscommit="dc72a20b7efd304d12af2025223fad07b4b78464"
+_quazipcommit="3691d57d3af13f49b2be2b62accddefee3c26b9c"
+source="
+ $pkgname-$pkgver.zip::https://github.com/MultiMC/MultiMC5/archive/$pkgver.zip
+ libnbtplus-$_libnbtpluscommit.zip::https://github.com/MultiMC/libnbtplusplus/archive/$_libnbtpluscommit.zip
+ quazip-$_quazipcommit.zip::https://github.com/MultiMC/quazip/archive/$_quazipcommit.zip
+ 01-patch-jar-path.patch
+"
+builddir="$srcdir/MultiMC5-$pkgver"
+
+build() {
+ export JAVA_HOME=/usr/lib/jvm/java-1.8-openjdk
+ mv ../libnbtplusplus-"$_libnbtpluscommit"/* libraries/libnbtplusplus
+ mv ../quazip-"$_quazipcommit"/* libraries/quazip
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=None \
+ -DMultiMC_LAYOUT=lin-system \
+ $CMAKE_CROSSOPTS .
+ make -C build
+}
+
+check() {
+ make test -C build
+}
+
+package() {
+ install -D application/resources/multimc/scalable/multimc.svg "$pkgdir"/usr/share/pixmaps/multimc.svg
+ install -D application/package/linux/multimc.desktop "$pkgdir"/usr/share/applications/multimc.desktop
+ make install -C build
+}
+sha512sums="4f9d54233dd6559f6ff786d35a0cb409761d50ec5bbb239b058f103b8a540c0cd5095d1324e8f42a7f011faecd6d658aff28faecb959201f73d9183fa69303b0 multimc-0.6.11.zip
+225f18b7cd7b56fbc9914b3e7db652ff98d8af44879cc82ad3ad511ee95d0d05b2b9efd572dea33bcbd8638d0dd80c8bf80c965a3580bc2de2b08cb6db783fd1 libnbtplus-dc72a20b7efd304d12af2025223fad07b4b78464.zip
+a00c120fd0e8ad5d72ab261170bc84dc6f2a0eb656af1645ba5aa9087d13d45e623c08cc578afc6f30e6d701524653da0ab619a095e0414949fb2e1fcbcd1413 quazip-3691d57d3af13f49b2be2b62accddefee3c26b9c.zip
+b928177fea7d0585facb82c5f40fa12a116a539b909dad47f14b4aaee7c31480475ef2370ea4a2a50ef585f96530a45c3735c082dda0bb33ed24aada4f48b33d 01-patch-jar-path.patch"