aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-06-02 11:55:44 -0400
committerLeo <thinkabit.ukim@gmail.com>2020-06-06 21:17:06 +0000
commit70b80b457a12bb48dfef50af75b1fd5d4e11f71f (patch)
treedadff65da1757ef39b211d54b199deb62277c100
parentf14dea04b749c42bee899c40743ac586ad9f864e (diff)
testing/k9s: new aport
https://k9scli.io Kubernetes TUI testing/
-rw-r--r--testing/k9s/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/k9s/APKBUILD b/testing/k9s/APKBUILD
new file mode 100644
index 00000000000..80e8e82ecf1
--- /dev/null
+++ b/testing/k9s/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=k9s
+_pkgname=github.com/derailed/k9s
+pkgver=0.20.2
+pkgrel=0
+_commit=218388c # git rev-parse --short HEAD
+_date=2020-06-02T15:50:42UTC # date -u -d @$(date +%s) +%FT%T%Z
+pkgdesc="Kubernetes TUI"
+url="https://k9scli.io"
+arch="all !x86" # tests fail on x86 for some reason
+license="Apache-2.0"
+makedepends="go"
+options="net chmod-clean"
+source="$pkgname-$pkgver.tar.gz::https://github.com/derailed/k9s/archive/v$pkgver.tar.gz"
+
+export GOPATH="$srcdir/go"
+export GOCACHE="$srcdir/go-build"
+export GOTMPDIR="$srcdir"
+
+build() {
+ local ldflags="-w -s -X $_pkgname/cmd.version=$pkgver -X $_pkgname/cmd.commit=$_commit -X $_pkgname/cmd.date=$_date"
+ go build -ldflags "$ldflags" -a -tags netgo -o execs/$pkgname main.go
+}
+
+check() {
+ go test ./...
+}
+
+package() {
+ install -Dm755 execs/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+sha512sums="4ba2dd5fbc7da084e33cd4688b6689395a13a2192867597dccf1057cb052598d03d87d03cd08d02e0c25f5cdaec786add2b0c019d8fbc0fd67841b3ae0993025 k9s-0.20.2.tar.gz"