aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-06-07 18:27:32 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-06-19 12:58:43 +0000
commit716d75cde8d7a694a98ef9fcc2f866b3f99e4857 (patch)
tree3edd19b9a1da7e3d0764c47bf5707b185b091f34
parent1d2483890a52499577f3443d02876fb507db3bee (diff)
main/abiword: add patch from upstream to fix black-screen regression
-rw-r--r--main/abiword/APKBUILD4
-rw-r--r--main/abiword/fix-black-drawing-regression.patch54
2 files changed, 57 insertions, 1 deletions
diff --git a/main/abiword/APKBUILD b/main/abiword/APKBUILD
index 6103d637eeb..1651e290d2b 100644
--- a/main/abiword/APKBUILD
+++ b/main/abiword/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=3.0.2
-pkgrel=0
+pkgrel=1
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
arch="all"
@@ -29,6 +29,7 @@ for _i in $_plugins; do
done
source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+ fix-black-drawing-regression.patch
fix-nullptr-c++98.patch"
builddir="$srcdir"/$pkgname-$pkgver
@@ -73,4 +74,5 @@ plugins() {
}
sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
+cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch
fbfedad9b58ba44fac53142fae77dce499b9d3f01acb2967e6507b94a8206436240e924ae420c1b92f707a0e08df9874c8de034532032cf6d8df9b28dcd8a3cf fix-nullptr-c++98.patch"
diff --git a/main/abiword/fix-black-drawing-regression.patch b/main/abiword/fix-black-drawing-regression.patch
new file mode 100644
index 00000000000..dbce8c696da
--- /dev/null
+++ b/main/abiword/fix-black-drawing-regression.patch
@@ -0,0 +1,54 @@
+From cec2fda355b67b5b814a803c5ed128c425cbb030 Mon Sep 17 00:00:00 2001
+From: Hubert Figuiere <hub@figuiere.net>
+Date: Thu, 8 Dec 2016 02:03:10 +0000
+Subject: [PATCH] Bug 13815 - draw event should return TRUE
+
+This fix the black drawing regression with Gtk3.22
+
+git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/branches/ABI-3-0-0-STABLE@35394 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
+---
+ src/af/xap/gtk/xap_UnixFrameImpl.cpp | 6 +++---
+ src/af/xap/gtk/xap_UnixFrameImpl.h | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+index 780000e..10f8e00 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
+ }
+
+ #if GTK_CHECK_VERSION(3,0,0)
+-gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
++gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
+ #else
+-gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
++gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ #endif
+ {
+ XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
+@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ pView->draw(&rClip);
+ #endif
+ }
+- return FALSE;
++ return TRUE;
+ }
+
+ static bool bScrollWait = false;
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
+index 30ee5d8..a0ff57f 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.h
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
+@@ -152,9 +152,9 @@ class XAP_UnixFrameImpl : public XAP_FrameImpl
+ static gint key_release_event(GtkWidget* w, GdkEventKey* e);
+ static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
+ #if GTK_CHECK_VERSION(3,0,0)
+- static gint draw(GtkWidget * w, cairo_t * cr);
++ static gboolean draw(GtkWidget * w, cairo_t * cr);
+ #else
+- static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
++ static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
+ #endif
+ static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
+ static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);