aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Bredbury <brebs@sent.com>2019-03-10 17:35:46 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-13 08:26:23 +0000
commit7279437ec7311315af9c10b05c200e16008ec2aa (patch)
tree4549bf83fdc96e8bcef9430dfb7e3fb0795e9e5c
parent0c16c3ce57d83682c4b37ff9649bd1d18d7852dd (diff)
testing/evolution-on: new aport
https://github.com/acidrain42/evolution-on Tray plugin for Evolution email client.
-rw-r--r--testing/evolution-on/APKBUILD38
-rw-r--r--testing/evolution-on/gconf-source-remove.patch14
-rw-r--r--testing/evolution-on/widget.patch23
3 files changed, 75 insertions, 0 deletions
diff --git a/testing/evolution-on/APKBUILD b/testing/evolution-on/APKBUILD
new file mode 100644
index 00000000000..f2951306540
--- /dev/null
+++ b/testing/evolution-on/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Paul Bredbury <brebs@sent.com>
+pkgname=evolution-on
+pkgver=3.24.2
+pkgrel=0
+pkgdesc="Tray plugin for Evolution email client"
+url="https://github.com/acidrain42/evolution-on"
+arch="x86_64" # Unknown whether works on other arches
+license="GPL-2.0-or-later"
+depends="evolution"
+makedepends="autoconf automake evolution-dev glib-dev gnome-common intltool libtool"
+source="$pkgname-$pkgver.tar.gz::https://github.com/acidrain42/$pkgname/archive/v$pkgver.tar.gz
+ gconf-source-remove.patch
+ widget.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ ./autogen.sh --prefix=/usr
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "${builddir}"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="7f6c048c052ecab2efefaeddaba9db8f7f63035c5505fce0b9c260b5cf2044fe0c4d90a2e7461e1643f507daa1d3a871be9c16e58311d229697d9ce11faa82cf evolution-on-3.24.2.tar.gz
+374fb2f1140d0edf514d1f63279c00414bd4c17dc33242b254f48db9f5bdadf12384f307105e76439e310bb6eccf51698beab9696f7ef0616876632421e64a85 gconf-source-remove.patch
+025b2b9e910bb85157a000c7e87ad9123b68d46c1cb9b69d65fd07330862b809e4e23282cec10c480bb7c033e80197278b0ffc7e57e9fa4052238d48e8aecfb9 widget.patch"
diff --git a/testing/evolution-on/gconf-source-remove.patch b/testing/evolution-on/gconf-source-remove.patch
new file mode 100644
index 00000000000..da447440b46
--- /dev/null
+++ b/testing/evolution-on/gconf-source-remove.patch
@@ -0,0 +1,14 @@
+To prevent:
+configure.ac:80: error: possibly undefined macro: AM_GCONF_SOURCE_2
+
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac 2017-05-09 18:21:44.000000000 +0100
++++ b/configure.ac 2019-03-10 17:14:20.222932063 +0000
+@@ -77,7 +77,6 @@
+ dnl GConf stuff
+ dnl ***********
+ AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
+-AM_GCONF_SOURCE_2
+
+ dnl ***************
+ dnl Libappindicator stuff
diff --git a/testing/evolution-on/widget.patch b/testing/evolution-on/widget.patch
new file mode 100644
index 00000000000..d999eb3c8b9
--- /dev/null
+++ b/testing/evolution-on/widget.patch
@@ -0,0 +1,23 @@
+From https://github.com/zsugabubus/evolution-on/commit/5f771627e2753febfdabd4f86230a8bfa29f0bb1
+
+From 5f771627e2753febfdabd4f86230a8bfa29f0bb1 Mon Sep 17 00:00:00 2001
+From: zsugabubus <zsugabubus@users.noreply.github.com>
+Date: Mon, 3 Sep 2018 14:50:02 +0200
+Subject: [PATCH] fix: remove that unnecessary `gtk_widget_show` call
+
+---
+ src/tray.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/tray.c b/src/tray.c
+index 366e3e4..cea6c74 100644
+--- a/src/tray.c
++++ b/src/tray.c
+@@ -95,7 +95,6 @@ toggle_window()
+ if (gtk_widget_get_visible(GTK_WIDGET(on_icon.evo_window))) {
+ gtk_widget_hide(GTK_WIDGET(on_icon.evo_window));
+ } else {
+- gtk_widget_show(GTK_WIDGET(on_icon.evo_window));
+ gtkut_window_popup(GTK_WIDGET(on_icon.evo_window));
+ }
+