aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-11-13 14:49:30 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-12-12 10:47:48 +0000
commit7288876a7ed8331f81e8c247af04431f1871fec7 (patch)
tree269f964f8a065bce1e5bc9401ca5217784b8f76b
parentceb6b48ceeceb988669d07f7c6eded1e1e01ad2c (diff)
testing/thunderbird: security upgrade to 78.5.1
-rw-r--r--testing/thunderbird/APKBUILD32
1 files changed, 27 insertions, 5 deletions
diff --git a/testing/thunderbird/APKBUILD b/testing/thunderbird/APKBUILD
index 4149693bd44..76151cc8c5c 100644
--- a/testing/thunderbird/APKBUILD
+++ b/testing/thunderbird/APKBUILD
@@ -1,13 +1,14 @@
# Contributor: Joseph Benden <joe@benden.us>
# Maintainer: Joseph Benden <joe@benden.us>
pkgname=thunderbird
-pkgver=78.3.2
-pkgrel=1
+pkgver=78.5.1
+pkgrel=0
pkgdesc="Thunderbird email client"
url="https://www.thunderbird.net/"
# Limited on:
# s390x, mips, mips64: limited by rust and cargo
# armhf: build failure on armhf due to wasm
+# ppc64le: Rust SIGSEGVs when compiling gkrust
arch="all !s390x !armhf !mips !mips64 !ppc64le"
license="GPL-3.0-or-later AND LGPL-2.1-or-later AND MPL-2.0"
options="!check"
@@ -34,6 +35,7 @@ makedepends="
alsa-lib-dev
autoconf2.13
automake
+ botan-dev
bsd-compat-headers
cargo
cbindgen
@@ -45,6 +47,7 @@ makedepends="
gtk+3.0-dev
hunspell-dev
icu-dev
+ json-c-dev
libevent-dev
libffi-dev
libidl-dev
@@ -93,7 +96,25 @@ source="https://ftp.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderb
thunderbird.desktop
"
+
# secfixes:
+# 78.5.1-r0:
+# - CVE-2020-15683
+# - CVE-2020-15969
+# - CVE-2020-15999
+# - CVE-2020-16012
+# - CVE-2020-26950
+# - CVE-2020-26951
+# - CVE-2020-26953
+# - CVE-2020-26956
+# - CVE-2020-26958
+# - CVE-2020-26959
+# - CVE-2020-26960
+# - CVE-2020-26961
+# - CVE-2020-26965
+# - CVE-2020-26966
+# - CVE-2020-26968
+# - CVE-2020-26970
# 68.10.0-r0:
# - CVE-2020-12417
# - CVE-2020-12418
@@ -136,7 +157,7 @@ source="https://ftp.mozilla.org/pub/thunderbird/releases/$pkgver/source/thunderb
# - CVE-2020-6792
# - CVE-2020-6800
-_mozappdir=/usr/lib/$pkgname
+_mozappdir=/usr/lib/thunderbird
# help our shared-object scanner to find the libs
ldpath="$_mozappdir"
@@ -194,7 +215,6 @@ build() {
../configure \
--prefix=/usr \
- --libdir=/usr/lib \
$_arch_config \
$_low_mem_flags \
$_rust_simd \
@@ -225,9 +245,11 @@ build() {
--enable-system-ffi \
--enable-system-pixman \
\
+ --with-system-botan \
--with-system-ffi \
--with-system-icu \
--with-system-jpeg \
+ --with-system-jsonc \
--with-system-libevent \
--with-system-libvpx \
--with-system-nspr \
@@ -309,7 +331,7 @@ package() {
ln -snf thunderbird "$pkgdir/$_mozappdir/thunderbird-bin"
}
-sha512sums="8c0beb2a54f34f9b06605ddc54443c8dbb4e376911bcfa2d5c4b235d4e6f484f1862afba977d0cfcac1222c1b738f967c9b74397ba99c84bd16cc70480a455d8 thunderbird-78.3.2.source.tar.xz
+sha512sums="3fb50ee1b5ec4bedaca0c68a86286f5141d3e350025b9d928348c55e57e07013124ef8b0315ee6cb16c08777ba8b0fb715ddc4b5fef2481e32f2b676090a2d80 thunderbird-78.5.1.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
4d55f41d15be7457ad630f8f07e4fc0314c2f75720010b4bbe6a2a7f3228210a1e069949e11795efbe2e784b0762e79fdfe5b8ec38e8a64cb8d9cf3b57dd5af1 fix-tools.patch