aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Marz <main@lmarz.org>2021-06-12 10:31:09 +0200
committerLeo <thinkabit.ukim@gmail.com>2021-06-12 10:38:43 +0000
commit73829f8bbd6c1dd56a42995ae5446be571125d1d (patch)
tree0091ea72fc8c5cc2215ccae2e8ea2a1dbf1bcc2d
parentd16eed94064539a7a1f0242709e8d7b76448c51a (diff)
testing/openvdb: upgrade to 8.1.0
-rw-r--r--testing/openvdb/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/testing/openvdb/APKBUILD b/testing/openvdb/APKBUILD
index 94ec9a54359..37de9a4daa2 100644
--- a/testing/openvdb/APKBUILD
+++ b/testing/openvdb/APKBUILD
@@ -1,13 +1,13 @@
-# Contributor: Leon Marz <lmarz@cs.uni-frankfurt.de>
-# Maintainer: Leon Marz <lmarz@cs.uni-frankfurt.de>
+# Contributor: Leon Marz <main@lmarz.org>
+# Maintainer: Leon Marz <main@lmarz.org>
pkgname=openvdb
-pkgver=8.0.1
-pkgrel=1
+pkgver=8.1.0
+pkgrel=0
pkgdesc="Sparse volume data structure and tools"
url="https://www.openvdb.org/"
arch="x86_64" # tests fail on all other arches
license="MPL-2.0"
-makedepends="cmake openexr-dev libtbb-dev zlib-dev boost-dev python3-dev gtest-dev"
+makedepends="cmake libtbb-dev boost-dev python3-dev gtest-dev"
subpackages="$pkgname-static $pkgname-dev py3-$pkgname:python"
source="$pkgname-$pkgver.tar.gz::https://github.com/AcademySoftwareFoundation/openvdb/archive/v$pkgver.tar.gz"
@@ -20,8 +20,7 @@ build() {
-DOPENVDB_BUILD_PYTHON_MODULE=ON \
-DOPENVDB_BUILD_UNITTESTS=ON \
-DOPENVDB_ENABLE_RPATH=OFF \
- -DUSE_BLOSC=OFF \
- -DUSE_EXR=ON
+ -DUSE_BLOSC=OFF
cmake --build build
}
@@ -40,4 +39,6 @@ python() {
amove /usr/lib/python3*
}
-sha512sums="6a5a8b637429295efa72494aef82ff92dd83092591b713f56930ccf4aab3a33806d1263bfd090c27239eab97b4fdc053288dc545e631f8a7d4ca180a32331be2 openvdb-8.0.1.tar.gz"
+sha512sums="
+081ccedb122ff9bd73e0cd7ff083ad0ff0165e0cf6305187edcbe90ff12f01ec085c91ad5c52c53596035e0c2afd5b8801e6c00374b0fc4b0cc111f5c7f37eb5 openvdb-8.1.0.tar.gz
+"