aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Yam <alex@alexyam.com>2021-02-17 22:18:27 +1100
committerLeo <thinkabit.ukim@gmail.com>2021-02-17 11:25:56 +0000
commit73e4d83aabe4fd5a1d95978a86b4e89755a9ec73 (patch)
tree00e47a41e639a8f93e41528039c5c9252caf60e2
parente6bfd7316a25f13da965e511dbca2203a21f8535 (diff)
testing/hexdiff: new aport
http://tboudet.free.fr/hexdiff/ ncurses hex editor with diff mode for binary file comparison
-rw-r--r--testing/hexdiff/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/hexdiff/APKBUILD b/testing/hexdiff/APKBUILD
new file mode 100644
index 00000000000..785d976ef1a
--- /dev/null
+++ b/testing/hexdiff/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Alex Yam <alex@alexyam.com>
+# Maintainer: Alex Yam <alex@alexyam.com>
+pkgname=hexdiff
+pkgver=0.0.50
+pkgrel=0
+pkgdesc="ncurses hex editor with diff mode for binary file comparison"
+url="http://tboudet.free.fr/hexdiff/"
+arch="all"
+license="GPL-2.0-or-later"
+depends="ncurses-dev"
+options="!check" # no test suite
+source="$pkgname-$pkgver.tar.gz::http://tboudet.free.fr/hexdiff/hexdiff.tar.gz"
+subpackages="$pkgname-doc"
+builddir="$srcdir/HexDiff"
+
+build() {
+ make
+}
+
+package() {
+ # broken 'make install'
+ install -Dm755 hexdiff -t $pkgdir/usr/bin
+ install -Dm644 hexdiff.1 -t $pkgdir/usr/share/man/man1
+ install -Dm644 hexdiff.rc -t "$pkgdir"/etc/hexdiff
+}
+
+sha512sums="3860aa286282604c2dc44fbb32329f28761cf16339dfa3c9f537e4fc2ec31742d59d19bc52935de979bb7397c7ee331846e528d3d2efe10e93ddc5d838fd3ce7 hexdiff-0.0.50.tar.gz"