aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-18 04:51:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-18 08:02:36 +0000
commit77f03f7d86e67dd0e79cec523edf11eb38082b9c (patch)
tree7445a4e6c00f10f999341c9000488dcbb48ff405
parent3a16880ee738e1fe31116d792dd5e8750db3534e (diff)
main/lua-alt-getopt: upgrade to 0.8.0
-rw-r--r--main/lua-alt-getopt/APKBUILD17
-rw-r--r--main/lua-alt-getopt/lua5.2-compat.patch77
2 files changed, 8 insertions, 86 deletions
diff --git a/main/lua-alt-getopt/APKBUILD b/main/lua-alt-getopt/APKBUILD
index c435abc3ba4..9d26a83d949 100644
--- a/main/lua-alt-getopt/APKBUILD
+++ b/main/lua-alt-getopt/APKBUILD
@@ -1,17 +1,17 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Contributor: Natanael Copa <ncopa@alpinlinux.org>
# Maintainer: Natanael Copa <ncopa@alpinlinux.org>
-_luaversions="5.1 5.2 5.3 5.4"
pkgname=lua-alt-getopt
-pkgver=0.7
-pkgrel=9
+pkgver=0.8.0
+pkgrel=0
pkgdesc="Lua module for processing options similar to getopt_long(3)"
-url="https://github.com/LuaDist/alt-getopt"
+url="https://github.com/cheusov/lua-alt-getopt"
arch="noarch"
license="MIT"
-source="alt-getopt-$pkgver.tar.gz::https://github.com/LuaDist/alt-getopt/archive/$pkgver.tar.gz
- lua5.2-compat.patch
+source="$pkgname-$pkgver.tar.gz::https://github.com/cheusov/lua-alt-getopt/archive/$pkgver.tar.gz
"
-builddir="$srcdir"/alt-getopt-$pkgver
+_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-alt-getopt:split_${_v/./_}"
@@ -43,5 +43,4 @@ for _v in $_luaversions; do
eval "split_${_v/./_}() { _split $_v; }"
done
-sha512sums="8e7d1a2686a320a47199a71d09da1d3fad51bfa086dd6b1a95414325a24c66c4bef9ac9dd1ec9d866248a3b292a47e6c12cef47e88ce79a7f99bc5eaea68afc7 alt-getopt-0.7.tar.gz
-9c4f44c811e1dd6164fb332bb95c23cff63f3347ee2e130b4bac08683a394cd3578425716a7cd49873ee35344d40414f03f5a30130c6a8fa4f94cd78cb0004f9 lua5.2-compat.patch"
+sha512sums="1c0768e98793ee060a8a70bc47355abf5feac3b51d9844a26816267c0901df9f30c9ef3280766dec2c5b754123ca548c8f49cb294bf4f04c378c62ea377e09de lua-alt-getopt-0.8.0.tar.gz"
diff --git a/main/lua-alt-getopt/lua5.2-compat.patch b/main/lua-alt-getopt/lua5.2-compat.patch
deleted file mode 100644
index 5ac65dba948..00000000000
--- a/main/lua-alt-getopt/lua5.2-compat.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From 86eb438ffb3580e6f7e82c17929d59c914dd46cb Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Peter=20Drahos=CC=8C?= <drahosp@gmail.com>
-Date: Wed, 16 May 2012 10:40:55 +0200
-Subject: [PATCH] Updated lua 5.2 compatibility
-
----
- CMakeLists.txt | 2 +-
- alt_getopt | 2 +-
- alt_getopt.lua | 11 +++++++----
- dist.info | 2 +-
- 4 files changed, 10 insertions(+), 7 deletions(-)
-
-diff --git a/alt_getopt b/alt_getopt
-index 4a48bf4..9fafee6 100755
---- a/alt_getopt
-+++ b/alt_getopt
-@@ -1,6 +1,6 @@
- #!/usr/bin/env lua
-
--require "alt_getopt"
-+local alt_getopt = require "alt_getopt"
-
- local long_opts = {
- verbose = "v",
-diff --git a/alt_getopt.lua b/alt_getopt.lua
-index 7a6591a..efba5ac 100644
---- a/alt_getopt.lua
-+++ b/alt_getopt.lua
-@@ -21,8 +21,6 @@
-
- local type, pairs, ipairs, io, os = type, pairs, ipairs, io, os
-
--module ("alt_getopt")
--
- local function convert_short2long (opts)
- local i = 1
- local len = #opts
-@@ -61,7 +59,7 @@ local function canonize (options, opt)
- return opt
- end
-
--function get_ordered_opts (arg, sh_opts, long_opts)
-+local function get_ordered_opts (arg, sh_opts, long_opts)
- local i = 1
- local count = 1
- local opts = {}
-@@ -150,7 +148,7 @@ function get_ordered_opts (arg, sh_opts, long_opts)
- return opts,i,optarg
- end
-
--function get_opts (arg, sh_opts, long_opts)
-+local function get_opts (arg, sh_opts, long_opts)
- local ret = {}
-
- local opts,optind,optarg = get_ordered_opts (arg, sh_opts, long_opts)
-@@ -164,3 +162,8 @@ function get_opts (arg, sh_opts, long_opts)
-
- return ret,optind
- end
-+
-+return {
-+ get_ordered_opts = get_ordered_opts,
-+ get_opts = get_opts,
-+}
-diff --git a/dist.info b/dist.info
-index 37f626a..02abf2a 100644
---- a/dist.info
-+++ b/dist.info
-@@ -1,7 +1,7 @@
- --- This file is part of LuaDist project
-
- name = "alt-getopt"
--version = "0.7"
-+version = "0.7-1"
-
- maintainer = "Peter Drahoš"
- desc = "Process application arguments the same way as getopt_long"